6.6. Configuring MVR

Overview

Function Introduction

Multicast VLAN Registration (MVR) is designed for applications using wide-scale deployment of multicast traffic across an Ethernet ring-based service provider network (for example, the broadcast of multiple television channels over a service-provider network). MVR allows a subscriber on a port to subscribe and unsubscribe to a multicast stream on the network-wide multicast VLAN. It allows the single multicast VLAN to be shared in the network while subscribers remain in separate VLANs. MVR provides the ability to continuously send multicast streams in the multicast VLAN, but to isolate the streams from the subscriber VLANs for bandwidth and security reasons.

MVR assumes that subscriber ports subscribe and unsubscribe (join and leave) these multicast streams by sending out IGMP join and leave messages. These messages can originate from an IGMP version-2-compatible host with an Ethernet connection. Although MVR operates on the underlying mechanism of IGMP snooping, the two features operation affect with each other. One can be enabled or disabled with affecting the behavior of the other feature. If IGMP snooping and MVR are both enabled, MVR reacts only to join and leave messages from multicast groups configured under MVR. The switch CPU identifies the MVR IP multicast streams and their associated MAC addresses in the switch forwarding table, intercepts the IGMP messages, and modifies the forwarding table to include or remove the subscriber as a receiver of the multicast stream, and the receivers must be in a different VLAN from the source. This forwarding behavior selectively allows traffic to cross between different VLANs.

Principle Description

Terminology:

Terminology

Description

MVR

Multicast Vlan Registration.

Source vlan

The vlan for receiving multicast traffic for MVR.

Source port

The port in the source vlan for sending report or leave to

upstream.

Receiver port

The port not in source vlan for receiving report or leave for

downstream.

Configuration

image

Fig. 6.4 MVR

Enable IGMP&PIM-SM in the interface of eth-0-1 of Switch1.

Configure Switch2: eth-0-1 in vlan111, eth-0-2 in vlan10, and eth-0-3 vlan30.

Enable MVR in the Switch2, it is required that only one copy of multicast traffic from Switch1 is sent to Switch2, but HostA and HostC can both receive this multicast traffic.

step 1 Enter the configure mode

Switch# configure terminal

step 2 Enter the vlan configure mode and create vlan

Configure on swich1:

Switch(config)# vlan database
Switch(config-vlan)# vlan 111,10,30
Switch(config-vlan)# quit

step 3 Enter the interface configure mode set the attributes and ip address, and enable pim-sm

Configure on swich1:

Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# no shutdown
Switch(config-if)# ip address 12.12.12.12/24
Switch(config-if)# ip pim sparse-mode
Switch(config-if)# exit

Configure on swich2:

Switch(config)# interface vlan 111
Switch(config-if)# exit
Switch(config)# interface vlan 10
Switch(config-if)# exit
Switch(config)# interface vlan 30
Switch(config-if)# exit
Switch(config)# interface eth-0-1
Switch(config-if)# switchport access vlan111
Switch(config)# interface eth-0-2
Switch(config-if)# switchport access vlan10
Switch(config)# interface eth-0-3
Switch(config-if)# switchport access vlan30
Switch(config-if)# exit

step 4 Enable MVR

Configure on swich2:

Switch(config)# no ip multicast-routing
Switch(config)# mvr
Switch(config)# mvr vlan 111
Switch(config)# mvr group 238.255.0.1 64
Switch(config)# mvr source-address 12.12.12.1
Switch(config)# interface eth-0-1
Switch(config-if)# mvr type source
Switch(config)# interface eth-0-2
Switch(config-if)# mvr type receiver vlan 10
Switch(config)# interface eth-0-3
Switch(config-if)# mvr type receiver vlan 30
Switch(config-if)# exit

step 5 Exit the configure mode

Switch(config)# end

step 6 Validation

Switch1:

Switch# show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
238.255.0.1 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.2 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.3 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.4 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.5 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.6 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.7 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.8 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.9 eth-0-1 00:01:16 00:03:49 12.12.12.1
238.255.0.10 eth-0-1 00:01:16 00:03:49 12.12.12.1
......
238.255.0.64 eth-0-1 00:01:16 00:03:49 12.12.12.1

Switch2:

Switch# show mvr
MVR Running: TRUE
MVR Multicast VLAN: 111
MVR Source-address: 12.12.12.1
MVR Max Multicast Groups: 1024
MVR Hw Rt Limit: 508
MVR Current Multicast Groups: 255
Switch# show mvr groups
VLAN Interface Group-Address Uptime Expires-time
10 eth-0-2 238.255.0.1 00:03:23 00:02:03
10 eth-0-2 238.255.0.2 00:02:16 00:02:03
10 eth-0-2 238.255.0.3 00:02:16 00:02:03
10 eth-0-2 238.255.0.4 00:02:16 00:02:03
10 eth-0-2 238.255.0.5 00:02:16 00:02:03
10 eth-0-2 238.255.0.6 00:02:16 00:02:04
10 eth-0-2 238.255.0.7 00:02:16 00:02:04
10 eth-0-2 238.255.0.8 00:02:16 00:02:04
10 eth-0-2 238.255.0.9 00:02:16 00:02:04
10 eth-0-2 238.255.0.10 00:02:16 00:02:04
......
10 eth-0-2 238.255.0.64 00:01:50 00:02:29

Application cases

N/A