Configuring IPv6 over IPv4 Tunnel
Overview
Function Introduction
Tunneling is an encapsulation technology, which uses one network protocol to encapsulate packets of another network protocol and transfer them over a virtual point-to-point connection. The virtual connection is called a tunnel. Tunneling refers to the whole process from data encapsulation to data transfer and data decapsulation.
Principle Description
IPv6 over IPv4 Tunnel
Overlay tunneling encapsulates IPv6 packets in IPv4 packets for delivery across an IPv4 infrastructure (a core network or the Internet. By using overlay tunnels, you can communicate with isolated IPv6 networks without upgrading the IPv4 infrastructure between them. Overlay tunnels can be configured between border routers or between a border router and a host; however, both tunnel endpoints must support both the IPv4 and IPv6 protocol stacks. The IPv6 over IPv4 tunnel processes packets in the following ways:
A host in the IPv6 network sends an IPv6 packet to Switch1 at the tunnel source.
After determining according to the routing table that the packet needs to be forwarded through the tunnel, Switch1 encapsulates the IPv6 packet with an IPv4 header and forwards it through the physical interface of the tunnel.
Upon receiving the packet, Switch2 decapsulates the packet.
Switch2 forwards the packet according to the destination address in the de-encapsulated IPv6 packet. If the destination address is the device itself, Switch2 forwards the IPv6 packet to the upper-layer protocol for processing.
The benefit of the technique is that current ipv4 networks do not need to update on all nodes. Only the edge nodes are required to support dual stack and tunnel.
IPv6 over IPv4 tunnels are divided into manually configured tunnels and automatic tunnels, depending on how the IPv4 address of the tunnel destination is acquired:
Manually configured tunnel: The destination address of the tunnel cannot be automatically acquired through the destination IPv6 address of an IPv6 packet at the tunnel source, and must be manually configured.
Automatic tunnel: The destination address of the tunnel is an IPv6 address with an IPv4 address embedded, and the IPv4 address can be automatically acquired through the destination IPv6 address of an IPv6 packet at the tunnel source.
Normally, system supports the following types of overlay tunneling mechanisms:
Manual
6to4
Intra-site Automatic Tunnel Addressing Protocol (ISATAP)
The details of the 3 types of overlay tunneling mechanisms are described below
Manual Tunnel
A manually configured tunnel is equivalent to a permanent link between two IPv6 domains over an IPv4 backbone. The primary use is for stable connections that require regular secure communication between two edge routers or between an end system and an edge router, or for connection to remote IPv6 networks.
An IPv6 address is manually configured on a tunnel interface, and manually configured IPv4 addresses are assigned to the tunnel source and the tunnel destination. The host or router at each end of a configured tunnel must support both the IPv4 and IPv6 protocol stacks. Manually configured tunnels can be configured between border routers or between a border router and a host.
6to4 Tunnel
Ordinary 6to4 tunnel
An automatic 6to4 tunnel allows isolated IPv6 domains to be connected over an IPv4 network to remote IPv6 networks. The key difference between automatic 6to4 tunnels and manually configured tunnels is that the tunnel is not point-to-point; it is point-to-multipoint. In automatic 6to4 tunnels, routers are not configured in pairs because they treat the IPv4 infrastructure as a virtual non-broadcast multi-access (NBMA) link. The IPv4 address embedded in the IPv6 address is used to find the other end of the automatic tunnel.
An automatic 6to4 tunnel may be configured on a border router in an isolated IPv6 network, which creates a tunnel on a per-packet basis to a border router in another IPv6 network over an IPv4 infrastructure. The tunnel destination is determined by the IPv4 address of the border router extracted from the IPv6 address that starts with the prefix 2002::/16, where the format is 2002:border-router-IPv4-address::/48.
Following the embedded IPv4 address are 16 bits that can be used to number networks within the site. The border router at each end of a 6to4 tunnel must support both the IPv4 and IPv6 protocol stacks. 6to4 tunnels are configured between border routers or between a border router and a host.
6to4 relay
A 6to4 tunnel is only used to connect 6to4 networks, whose IP prefix must be 2002::/16. However, IPv6 network addresses with the prefix such as 2001::/16 may also be used in IPv6 networks. To connect a 6to4 network to an IPv6 network, a 6to4 router must be used as a gateway to forward packets to the IPv6 network. Such a router is called 6to4 relay router.
IPv6 over IPv4 Tunnel
As shown in the above figure, a static route must be configured on the border router (Switch1) in the 6to4 network and the next-hop address must be the 6to4 address of the 6to4 relay router (Switch3). In this way, all packets destined for the IPv6 network will be forwarded to the 6to4 relay router, and then to the IPv6 network. Thus, interworking between the 6to4 network (with the address prefix starting with 2002) and the IPv6 network is realized.
ISATAP Tunnel
ISATAP is an automatic overlay tunneling mechanism that uses the underlying IPv4 network as a NBMA link layer for IPv6. ISATAP is designed for transporting IPv6 packets within a site where a native IPv6 infrastructure is not yet available; for example, when sparse IPv6 hosts are deployed for testing. ISATAP tunnels allow individual IPv4 or IPv6 dual-stack hosts within a site to communicate with other such hosts on the same virtual link, basically creating an IPv6 network using the IPv4 infrastructure.
When an ISATAP tunnel is used, the destination address of an IPv6 packet and the IPv6 address of a tunnel interface both adopt special ISATAP addresses. ISATAP uses a well-defined IPv6 address format composed of any unicast IPv6 prefix (/64), which can be link local, or global (including 6to4 prefixes), enabling IPv6 routing locally or on the Internet. The IPv4 address is encoded in the last 32 bits of the IPv6 address, enabling automatic IPv6-in-IPv4 tunneling. The ISATAP address format is prefix(64bit):0:5EFE: IPv4-address.
ISATAP Tunnel
The ISATAP router provides standard router advertisement network configuration support for the ISATAP site. This feature allows clients to automatically configure themselves as they would do if they were connected to an Ethernet. It can also be configured to provide connectivity out of the site.
Although the ISATAP tunneling mechanism is similar to other automatic tunneling mechanisms, such as IPv6 6to4 tunneling, ISATAP is designed for transporting IPv6 packets within a site, not between sites.
Configuration
Configure Manual Tunnel
Manual Tunnel
As shown in the above Figure, two IPv6 networks are connected over an IPv4 network. Configure an IPv6 manual tunnel between Switch1 and Switch2 to make the two IPv6 networks reachable to each other.
Must enable IPv6/IPv4 dual stack before tunnel configuration.
Make sure tunnel destination is reachable in the IPv4 network.
There must exist an IPv6 address in the tunnel interface, otherwise routes with tunnel interface as nexthop will be invalid.
The following configuration should be operated on all switches if the switch ID is not specified.
step 1 Enter the configure mode
Switch# configure terminal
step 2 Enable ipv6 globally
Switch(config)# ipv6 enable
step 3 Enter the interface configure mode and set the attributes of the interface
Interface configuration for Switch1:
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.168.10.1/24
Switch(config-if)# tunnel enable
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ipv6 address 3002::1/64
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface tunnel1
Switch(config-if)# tunnel source eth-0-1
Switch(config-if)# tunnel destination 192.168.20.1
Switch(config-if)# tunnel mode ipv6ip
Switch(config-if)# ipv6 address 3001::1/64
Switch(config-if)# exit
Interface configuration for Switch2:
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.168.20.1/24
Switch(config-if)# tunnel enable
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ipv6 address 3003::1/64
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface tunnel1
Switch(config-if)# tunnel source eth-0-1
Switch(config-if)# tunnel destination 192.168.10.1
Switch(config-if)# tunnel mode ipv6ip
Switch(config-if)# ipv6 address 3001::2/64
Switch(config-if)# exit
step 4 Create static routes
Configuring Switch1:
Switch(config)# ip route 192.168.20.0/24 192.168.10.2
Switch(config)# ipv6 route 3003::/16 tunnel1
Configuring Switch2:
Switch(config)# ip route 192.168.10.0/24 192.168.20.2
Switch(config)# ipv6 route 3002::/16 tunnel1
step 5 Configuring static arp
Configuring Switch1:
Switch(config)# arp 192.168.10.2 0.0.2222
Configuring Switch2:
Switch(config)# arp 192.168.20.2 0.0.1111
step 6 Exit the configure mode
Switch(config)# end
step 7 Validation
Display the result on Switch1:
Switch# show interface tunnel1
Interface tunnel1
Interface current state: UP
Hardware is Tunnel
Index 8193 , Metric 1 , Encapsulation TUNNEL
VRF binding: not bound
Tunnel protocol/transport IPv6/IP, Status Valid
Tunnel source 192.168.10.1(eth-0-1), destination 192.168.20.1
Tunnel DSCP inherit, Tunnel TTL 64
Tunnel transport MTU 1480 bytes
Switch1 show ipv6 interface tunnel1
Interface current state: UP
The maximum transmit unit is 1480 bytes
IPv6 is enabled, link-local address is fe80::c0a8:a01
Global unicast address(es):
3001::1, subnet is 3001::/64
ICMP error messages limited to one every 1000 milliseconds
ICMP redirects are always sent
ND DAD is enabled, number of DAD attempts: 1
ND router advertisement is disabled
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND retransmit interval is 1000 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements max interval: 600 secs
ND router advertisements min interval: 198 secs
ND router advertisements live for 1800 seconds
ND router advertisements hop-limit is 0
Hosts use stateless autoconfig for addresses.
Display the result on Switch2:
Switch# show interface tunnel1
Interface tunnel1
Interface current state: UP
Hardware is Tunnel
Index 8193 , Metric 1 , Encapsulation TUNNEL
VRF binding: not bound
Tunnel protocol/transport IPv6/IP, Status Valid
Tunnel source 192.168.20.1(eth-0-1), destination 192.168.10.1
Tunnel DSCP inherit, Tunnel TTL 64
Tunnel transport MTU 1480 bytes
Switch1 show ipv6 interface tunnel1
Interface current state: UP
The maximum transmit unit is 1480 bytes
IPv6 is enabled, link-local address is fe80::c0a8:1401
Global unicast address(es):
3001::2, subnet is 3001::/64
ICMP error messages limited to one every 1000 milliseconds
ICMP redirects are always sent
ND DAD is enabled, number of DAD attempts: 1
ND router advertisement is disabled
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND retransmit interval is 1000 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements max interval: 600 secs
ND router advertisements min interval: 198 secs
ND router advertisements live for 1800 seconds
ND router advertisements hop-limit is 0
Hosts use stateless autoconfig for addresses.
Configure 6to4 Tunnel
6to4 tunnel
As shown in the above Figure, two 6to4 networks are connected to an IPv4 network through two 6to4 routers (Switch1 and Switch2) respectively. Configure a 6to4 tunnel to make Host1 and Host2 reachable to each other.
To enable communication between 6to4 networks, you need to configure 6to4 addresses for 6to4 routers and hosts in the 6to4 networks.
The IPv4 address of eth-0-1 on Switch1 is 2.1.1.1/24, and the corresponding 6to4 prefix is 2002:0201:0101::/48 after it is translated to an IPv6 address. Assign interface tunnel 1 to subnet 2002:0201:0101::/64 and eth-0-2 to subnet 2002:0201:0101:1::/64.
The IPv4 address of eth-0-1 on Switch2 is 5.1.1.1/24, and the corresponding 6to4 prefix is 2002:0501:0101::/48 after it is translated to an IPv6 address. Assign interface tunnel 1 to subnet 2002:0501:0101::/64 and eth-0-2 to subnet 2002:0501:0101:1::/64.
No destination address needs to be configured for a 6to4 tunnel
The automatic tunnel interfaces using the same encapsulation protocol cannot share the same source IP address
To encapsulate and forward IPv6 packets whose destination address does not belong to the network segment where the receiving tunnel interface resides, you need to configure a static route to reach the destination IPv6 address through this tunnel interface on the router. Because automatic tunnels do not support dynamic routing, you can configure a static route to that destination IPv6 address with this tunnel interface as the outbound interface or the peer tunnel interface address as the next hop
Only on4 6to4 tunnel can exist in the same node.
The following configuration should be operated on all switches if the switch ID is not specified.
step 1 Enter the configure mode
Switch# configure terminal
step 2 Enable ipv6 globally
Switch(config)# ipv6 enable
step 3 Enter the interface configure mode and set the attributes of the interface
Interface configuration for Switch1:
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 2.1.1.1/24
Switch(config-if)# tunnel enable
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ipv6 address 2002:201:101:1::1/64
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface tunnel1
Switch(config-if)# tunnel source eth-0-1
Switch(config-if)# tunnel mode ipv6ip 6to4
Switch(config-if)# ipv6 address 2002:201:101::1/64
Switch(config-if)# exit
Interface configuration for Switch2:
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 5.1.1.1/24
Switch(config-if)# tunnel enable
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ipv6 address 2002:501:101:1::1/64
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface tunnel1
Switch(config-if)# tunnel source eth-0-1
Switch(config-if)# tunnel mode ipv6ip 6to4
Switch(config-if)# ipv6 address 2002:501:101::1/64
Switch(config-if)# exit
step 4 Create static routes
Configuring Switch1:
Switch(config)# ip route 5.1.1.0/24 2.1.1.2
Switch(config)# ipv6 route 2002::/16 tunnel1
Configuring Switch2:
Switch(config)# ip route 2.1.1.0/24 5.1.1.2
Switch(config)# ipv6 route 2002::/16 tunnel1
step 5 Configuring static arp
Configuring Switch1:
Switch(config)# arp 2.1.1.2 0.0.2222
Configuring Switch2:
Switch(config)# arp 5.1.1.2 0.0.1111
step 6 Exit the configure mode
Switch(config)# end
step 7 Validation
Display the result on Switch1:
Switch1 show interface tunnel1
Interface tunnel1
Interface current state: UP
Hardware is Tunnel
Index 8193 , Metric 1 , Encapsulation TUNNEL
VRF binding: not bound
Tunnel protocol/transport IPv6/IP 6to4, Status Valid
Tunnel source 2.1.1.1(eth-0-1), destination UNKNOWN
Tunnel DSCP inherit, Tunnel TTL 64
Tunnel transport MTU 1480 bytes
Display the result on Switch2:
Switch2 show interface tunnel1
Interface tunnel1
Interface current state: UP
Hardware is Tunnel
Index 8193 , Metric 1 , Encapsulation TUNNEL
VRF binding: not bound
Tunnel protocol/transport IPv6/IP 6to4, Status Valid
Tunnel source 5.1.1.1(eth-0-1), destination UNKNOWN
Tunnel DSCP inherit, Tunnel TTL 64
Tunnel transport MTU 1480 bytes
Configure 6to4 relay
6to4 relay
As shown in the above Figure, Switch1 is a 6to4 router, and 6to4 addresses are used on the connected IPv6 network. Switch2 serves as a 6to4 relay router and is connected to the IPv6 network (2001::/16). Configure a 6to4 tunnel between Router A and Router B to make Host A and Host B reachable to each other.
The configuration on a 6to4 relay router is similar to that on a 6to4 router. However, to enable communication between the 6to4 network and the IPv6 network, you need to configure a route to the IPv6 network on the 6to4 router.
It is not allowed to change the tunnel mode from 6to4 to ISATAP when there are any 6to4 relay routes existing. You must delete this route first.
The following configuration should be operated on all switches if the switch ID is not specified.
step 1 Enter the configure mode
Switch# configure terminal
step 2 Enable ipv6 globally
Switch(config)# ipv6 enable
step 3 Enter the interface configure mode and set the attributes of the interface
Interface configuration for Switch1:
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 2.1.1.1/24
Switch(config-if)# tunnel enable
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ipv6 address 2002:201:101:1::1/64
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface tunnel1
Switch(config-if)# tunnel source eth-0-1
Switch(config-if)# tunnel mode ipv6ip 6to4
Switch(config-if)# ipv6 address 2002:201:101::1/64
Switch(config-if)# exit
Interface configuration for Switch2:
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 5.1.1.1/24
Switch(config-if)# tunnel enable
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ipv6 address 2002:501:101:1::1/64
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface tunnel1
Switch(config-if)# tunnel source eth-0-1
Switch(config-if)# tunnel mode ipv6ip 6to4
Switch(config-if)# ipv6 address 2002:501:101::1/64
Switch(config-if)# exit
step 4 Create static routes
Configuring Switch1:
Switch(config)# ip route 6.1.1.0/24 2.1.1.2
Switch(config)# ipv6 route 2001::/16 2002:601:101::1
Switch(config)# ipv6 route 2002:601:101::/48 tunnel1
Configuring Switch2:
Switch(config)# ip route 2.1.1.0/24 6.1.1.2
Switch(config)# ipv6 route 2002::/16 tunnel1
step 5 Configuring static arp
Configuring Switch1:
Switch(config)# arp 2.1.1.2 0.0.2222
Configuring Switch2:
Switch(config)# arp 6.1.1.2 0.0.1111
step 6 Exit the configure mode
Switch(config)# end
step 7 Validation
Display the result on Switch1:
Switch# show interface tunnel1
Interface tunnel1
Interface current state: UP
Hardware is Tunnel
Index 8193 , Metric 1 , Encapsulation TUNNEL
VRF binding: not bound
Tunnel protocol/transport IPv6/IP 6to4, Status Valid
Tunnel source 2.1.1.1(eth-0-1), destination UNKNOWN
Tunnel DSCP inherit, Tunnel TTL 64
Tunnel transport MTU 1480 bytes
Switch# show ipv6 route
IPv6 Routing Table
Codes: C - connected, S - static, R - RIP, O - OSPF, I - IS-IS, B -
BGP | [*] - [AD/Metric]
Timers: Uptime
S 2001::/16 \[1/0\]
via 2002:601:101::1 (recursive via ::, tunnel1), 00:00:32
C 2002:201:101::/64
via ::, tunnel1, 00:00:04
C 2002:201:101::1/128
via ::1, tunnel1, 00:00:04
S 2002:601:101::/48 \[1/0\]
via ::, tunnel1, 00:00:22
Switch# show ipv6 interface tunnel1
Interface tunnel1
Interface current state: UP
The maximum transmit unit is 1480 bytes
IPv6 is enabled, link-local address is fe80::201:101
Global unicast address(es):
2002:201:101::1, subnet is 2002:201:101::/64
ICMP error messages limited to one every 1000 milliseconds
ICMP redirects are always sent
ND DAD is enabled, number of DAD attempts: 1
ND router advertisement is disabled
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND retransmit interval is 1000 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements max interval: 600 secs
ND router advertisements min interval: 198 secs
ND router advertisements live for 1800 seconds
ND router advertisements hop-limit is 0
Hosts use stateless autoconfig for addresses.
Display the result on Switch2:
Switch# show interface tunnel1
Interface tunnel1
Interface current state: UP
Hardware is Tunnel
Index 8193 , Metric 1 , Encapsulation TUNNEL
VRF binding: not bound
Tunnel protocol/transport IPv6/IP 6to4, Status Valid
Tunnel source 6.1.1.1(eth-0-1), destination UNKNOWN
Tunnel DSCP inherit, Tunnel TTL 64
Tunnel transport MTU 1480 bytes
Configure ISATAP Tunnel
ISATAP tunnel
As shown in the above Figure, an IPv6 network is connected to an IPv4 network through an ISATAP router. It is required that the IPv6 host in the IPv4 network can access the IPv6 network through the ISATAP tunnel.
No destination address needs to be configured for a ISATAP tunnel
The automatic tunnel interfaces using the same encapsulation protocol cannot share the same source IP address
To encapsulate and forward IPv6 packets whose destination address does not belong to the network segment where the receiving tunnel interface resides, you need to configure a static route to reach the destination IPv6 address through this tunnel interface on the router. Because automatic tunnels do not support dynamic routing, you can configure a static route to that destination IPv6 address with this tunnel interface as the outbound interface or the peer tunnel interface address as the next hop
step 1 Enter the configure mode
Switch# configure terminal
step 2 Enable ipv6 globally
Switch(config)# ipv6 enable
step 3 Enter the interface configure mode and set the attributes of the interface
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 1.1.1.1/24
Switch(config-if)# tunnel enable
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ipv6 address 3001::1/64
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface tunnel1
Switch(config-if)# tunnel source eth-0-1
Switch(config-if)# tunnel mode ipv6ip isatap
Switch(config-if)# ipv6 address 2001::/64 eui-64
Switch(config-if)# no ipv6 nd ra suppress
Switch(config-if)# exit
step 4 Create static routes
Switch(config)# ip route 2.1.1.0/24 1.1.1.2
Switch(config)# ipv6 route 2001::/16 tunnel1
step 5 Configuring static arp
Switch(config)# arp 1.1.1.2 0.0.2222
step 6 Exit the configure mode
Switch(config)# end
step 7 Validation
Switch# show interface tunnel1
Interface tunnel1
Interface current state: UP
Hardware is Tunnel
Index 8193 , Metric 1 , Encapsulation TUNNEL
VRF binding: not bound
Tunnel protocol/transport IPv6/IP ISATAP, Status Valid
Tunnel source 1.1.1.1(eth-0-1), destination UNKNOWN
Tunnel DSCP inherit, Tunnel TTL 64
Tunnel transport MTU 1480 bytes
Switch# show ipv6 interface tunnel1
Interface tunnel1
Interface current state: UP
The maximum transmit unit is 1480 bytes
IPv6 is enabled, link-local address is fe80::101:101
Global unicast address(es):
2001::101:101, subnet is 2001::/64 \[EUI\]
ICMP error messages limited to one every 1000 milliseconds
ICMP redirects are always sent
ND DAD is enabled, number of DAD attempts: 1
ND router advertisement is enabled
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND retransmit interval is 1000 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements max interval: 600 secs
ND router advertisements min interval: 198 secs
ND next router advertisement due in 359 secs.
ND router advertisements live for 1800 seconds
ND router advertisements hop-limit is 0
Hosts use stateless autoconfig for addresses.
Configure ISATAP host
The specific configuration on the ISATAP host is related to its operating system. The following example shows the configuration of the host running the Windows XP.
Install IPv6.
C:>ipv6 install
On a Windows XP-based host, the ISATAP interface is usually interface 2. Configure the IPv4 address of the ISATAP router on interface 2 to complete the configuration on the host. Before that, display information on the ISATAP interface:
Interface 2: Automatic Tunneling Pseudo-Interface
Guid {48FCE3FC-EC30-E50E-F1A7-71172AEEE3AE}
does not use Neighbor Discovery
does not use Router Discovery
routing preference 1
EUI-64 embedded IPv4 address: 0.0.0.0
router link-layer address: 0.0.0.0
preferred link-local fe80::5efe:2.1.1.1, life infinite
link MTU 1280 (true link MTU 65515)
current hop limit 128
reachable time 25000ms (base 30000ms)
retransmission interval 1000ms
DAD transmits 0
default site prefix length 48
A link-local address (fe80::5efe:2.1.1.2) in the ISATAP format was automatically generated for the ISATAP interface. Configure the IPv4 address of the ISATAP router on the ISATAP interface.
C:>ipv6 rlu 2 1.1.1.1
After carrying out the above command, look at the information on the ISATAP interface.
Interface 2: Automatic Tunneling Pseudo-Interface
Guid {48FCE3FC-EC30-E50E-F1A7-71172AEEE3AE}
does not use Neighbor Discovery
does not use Router Discovery
routing preference 1
EUI-64 embedded IPv4 address: 2.1.1.1
router link-layer address: 1.1.1.1
preferred global 2001::5efe:2.1.1.1, life 29d23h59m46s/6d23h59m46s
(public)
preferred link-local fe80::5efe:2.1.1.1, life infinite
link MTU 1280 (true link MTU 65515)
current hop limit 128
reachable time 25000ms (base 30000ms)
retransmission interval 1000ms
DAD transmits 0
default site prefix length 48
Application cases {application-cases-85}
N/A