17.2. EVPN Commands
17.2.1. address-family l2vpn evpn
Command Purpose
Use this command to enter EVPN address family configure mode.
Use the no parameter of this command to cancel EVPN configuration in BGP.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
address-family l2vpn evpn
no address-family l2vpn evpn
Command Mode
Router Configuration
Default
None
Usage
Use the address family command to enter the address family mode allowing configuration of address-family specific parameters. To leave the address family mode and return to the Configure mode use the exit-address-family command.
EVPN feature should be enabled before enter this address family configure mode.
Examples
The following example shows how to EVPN address family configure mode:
Switch# configure terminal
Switch(config)# router bgp 1
Switch(config-router)# address-family l2vpn evpn
Switch(config-router-af)#
17.2.2. debug overlay evpn
Command Purpose
Use this command to enable all EVPN troubleshooting functions on Overlay.
Use no format of this command to disable this configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug overlay evpn
no debug overlay evpn
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to debug EVPN on overlay:
Switch# debug overlay evpn
Related Commands
overlay host-collect
17.2.3. evpn
Command Purpose
Use this command to enable EVPN function and enter EVPN configure mode.
Use no format of this command to disable EVPN function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
evpn
no evpn
Command Mode
Global Config
Default
Disable
Usage
This command can enable EVPN function. And after entering EVPN configure mode, EVPN instance can be created. When the function had been disabled, all EVPN instances will be deleted.
Examples
The following example shows how to enable EVPN function:
Switch# configure terminal
Switch(config)# evpn
Switch(config-evpn)#
Related Commands
address-family l2vpn evpn
17.2.4. overlay host-collect
Command Purpose
Use this command to enable host information collection.
Use no format of the command to disable this configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
overlay host-collect (enable|disable)
Command Mode
Interface Configuration
Default
Disable
Usage
After host collection was enabled and both RD and route-target of EVPN instance was configured, host information from dynamic ARP will be sent to BGP module to format and advertise EVPN type 2 route.
Examples
The following example shows how to enable host information collection on interface:
Switch# configure terminal
Switch(config)# interface vlan 100
Switch(config-if)# overlay host-collect enable
Related Commands
evpn
17.2.5. rd
Command Purpose
Use this command to set route distinguisher for EVPN instance.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
rd (auto|RD-VALUE)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
auto |
Automatically generates an RD in the N:VXLAN ID format |
- |
RD-VALUE |
Route distinguisher value. ASN:nn or IP:nn |
ASN range is 1-4294967295nn range is 1-65535 |
Command Mode
EVI Configuration
Default
None
Usage
None
Examples
The following example shows how to set RD:
Switch# configure terminal
Switch(config)# evpn
Switch(config-evpn)# vni 100
Switch(config-evi)# rd auto
Related Commands
vni
17.2.6. route-target
Command Purpose
Use this command to set route target for EVPN instance.
Use no format of the command to cancel the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
route-target (import|export|both) (auto|RT-VALUE)
no route-target (import|export|both) (auto|RT-VALUE)
no route-target (import|export|both| )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
import |
Import direction |
- |
export |
Export direction |
- |
both |
Import and export direction |
- |
auto |
Automatically generates an route target |
- |
RT-VALUE |
Route target value. ASN:nn or IP:nn |
ASN range is 1-4294967295nn range is 1-65535 |
Command Mode
EVI Configuration
Default
None
Usage
None
Examples
The following example shows how to set route target:
Switch# configure terminal
Switch(config)# evpn
Switch(config-evpn)# vni 100
Switch(config-evi)# route-target both auto
Related Commands
vni
17.2.7. route-target evpn
Command Purpose
Use this command to set route target for EVPN instance in VRF mode.
Use no format of the command to cancel the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
route-target (import|export|both) (RT-VALUE) evpn
no route-target (import|export|both) (auto|RT-VALUE)
no route-target (import|export|both| )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
import |
Import direction |
- |
export |
Export direction |
- |
both |
Import and export direction |
- |
RT-VALUE |
Route target value. ASN:nn or IP:nn |
ASN range is 1-4294967295nn range is 1-65535 |
Command Mode
VRF Configuration
Default
None
Usage
None
Examples
The following example shows how to set route target:
Switch# configure terminal
Switch(config)# ip vrf a
Switch(config-vrf)# route-target both 1:1 evpn
Related Commands
vxlan vni
17.2.8. neighbor attribute-unchanged
Command Purpose
Use this command to advertise unchanged BGP attributes to the specified neighbor.
Use no format with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
neighbor (IP_ADDR|WORD) attribute-unchanged next-hop
no neighbor (IP_ADDR|WORD) attribute-unchanged next-hop
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR |
Specifies the address of the BGP neighbor in IPv4 format |
IPv4 Address |
WORD |
Name of an existing peer-group |
Up to 20 characters |
Command Mode
Address Family Configuration
Default
None
Usage
None
Examples
The following example shows how to set nexthop unchanged attribute:
Switch# configure terminal
Switch(config)# router bgp 1
Switch(config-router)# address-family l2vpn evpn
Switch(config-router-af)# neighbor 1.1.1.1 attribute-unchanged next-hop
Related Commands
address-family l2vpn evpn
17.2.9. neighbor send-community
Command Purpose
Use this command to specify that a community attribute should be sent to a BGP neighbor.
Use no format with this command to remove the entry.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
neighbor (IP_ADDR|WORD) (both|extended|standard)
no neighbor (IP_ADDR|WORD) (both|extended|standard)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR |
Specifies the address of the BGP neighbor in IPv4 format |
- |
WORD |
Name of an existing peer-group |
Up to 20 characters |
both |
Sends Standard and Extended Community attributes |
- |
extended |
Sends Extended Community attributes |
- |
standard |
Sends Standard Community attributes |
- |
Command Mode
Address Family Configuration
Default
None
Usage
None
Examples
The following example shows how to set send-community attribute:
Switch# configure terminal
Switch(config)# router bgp 1
Switch(config-router)# address-family l2vpn evpn
Switch(config-router-af)# neighbor 1.1.1.1 send-community extended
Related Commands
address-family l2vpn evpn
17.2.10. neighbor route-reflector-client
Command Purpose
Use this command to configure the router as a BGP route reflector and configure the specified neighbor as its client.
Use the no parameter with this command to indicate that the neighbor is not a client.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
neighbor NEIGHBORID route-reflector-client
no neighbor NEIGHBORID route-reflector-clien
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NEIGHBORID |
(A.B.C.D|TAG) |
- |
IP_ADDR |
Specifies the address of the BGP neighbor in IPv4 format. |
IPv4 Address |
TAG |
Name of an existing peer-group. For information on how to create peer groups, refer to the neighbor peer-group and neighbor remote-as commands. When this parameter is used with a command, the command applies on all peers in the specified group. |
- |
Command Mode
Address Family Configuration
Default
N/A
Usage
Route reflectors are a solution for the explosion of iBGP peering withinan autonomous system. By route reflection the number of iBGP peerswithin an AS is reduced. Use the neighbor route-reflector-client commandto configure the local router as the route reflector and specify neighbors as its client.
An AS can have more than one route reflector. One route reflector treats the other route reflector as another iBGP speaker.
Examples
Switch# configure terminal
Switch(config)# router bgp 1
Switch(config-router)# address-family l2vpn evpn
Switch(config-router-af)# neighbor 10.10.0.72 route-reflector-client
Related Commands
N/A
17.2.11. retain route-target all
Command Purpose
Use this command to configure the BGP route would not delete when they are not duplicated into EVPN instance.
Use no format of this command to cancel the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
retain route-target all
Command Mode
Address Family Configuration
Default
None
Usage
When the BGP would be used for transmitting the BGP route as the underlay network, it should set this configuration.
Examples
The following example shows how to set this configuraion:
Switch# configure terminal
Switch(config)# router bgp 1
Switch(config-router)# address-family l2vpn evpn
Switch(config-router-af)# retain route-target all
Related Commands
evpn
17.2.12. advertise l2vpn evpn
Command Purpose
Use this command to configure the BFP VRF instance route could be advertised into the EVPN instance.
Use no format of this command to cancel the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
advertise l2vpn evpn
Command Mode
Address Family Configuration
Default
None
Usage
When it is needed to advertise the route of VRF instance to the EVPN instance as type5 route, it should set this configuration.
Examples
The following example shows how to set this configuraion:
Switch# configure terminal
Switch(config)# router bgp 1
Switch(config-router)# address-family ipv4 vrf a
Switch(config-router-af)# advertise l2vpn evpn
Related Commands
evpn
17.2.13. vni
Command Purpose
Use this command to create EVPN instance.
Use no format of this command to cancel the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
vni VAL
no vni VAL
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
VAL |
The ID of VNI |
1 - 16777215 |
Command Mode
EVPN Configuration
Default
None
Usage
The EVPN instance will be ready until both RD and route-target is set.
Examples
The following example shows how to create an EVPN instance:
Switch# configure terminal
Switch(config)# evpn
Switch(config-evpn)# vni 2001
Switch(config-evi)#
Related Commands
evpn
17.2.14. vxlan vni
Command Purpose
Use this command to create EVPN instance of VRF.
Use no format of this command to cancel the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
vxlan vni VAL
no vxlan vni VAL
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
VAL |
The ID of VNI |
1 - 16777215 |
Command Mode
EVPN Configuration
Default
None
Usage
The EVPN instance will be ready until both RD and route-target is set.
Examples
The following example shows how to create an EVPN instance:
Switch# configure terminal
Switch(config)# ip vrf a
Switch(config-vrf)# vxlan vni 1000
Related Commands
evpn
17.2.15. vxlan uplink
Command Purpose
Use the VXLAN uplink command to enable or disable VXLAN uplink port capability.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
vxlan uplink (enable|disable)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
enable |
Make VXLAN uplink port enable |
- |
disable |
Make VXLAN uplink port disable |
- |
Command Mode
Interface Configuration
Default
Disable
Usage
The command is allow setting on ether type port. This command is used to decapsulated the VXLAN packet for L2 VNI and L3 VNI
Examples
This example shows how to enable VXLAN uplink on interface:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# vxlan uplink enable
Related Commands
None
17.2.16. interface nve
Command Purpose
Use this command to create an interface NVE.
Use no format of this command to cancel the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
interface nve IFNVE
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNVE |
The index of NVE if |
0 - 3 |
Command Mode
Global Config
Default
None
Usage
There are four NVEs configured because of four source IP address of overlay
Examples
The following example shows how to create an interface NVE:
Switch# configure terminal
Switch(config)# interface nve 1
Related Commands
show interface nve
17.2.17. source
Command Purpose
Use this command to set the overlay source VTEP IP address of NVE.
To remove the source VTEP IP address of NVE, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
source (IP_ADDR|IFNAME)
no source
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR |
The overlay source VTEP IP address of NVE, it should be a valid interface IP address. |
IPv4 Address |
IFNAME |
The overlay source interface of NVE must have primary IP address |
Aggregation, physical, VLAN and loopback interface |
Command Mode
Interface Configuration
Default
None
Usage
Overlay source VTEP IP address is used to encap and decap overlay packets. It is recommended that the source VTEP IP address is the same with some loopback interface address so that IP routing can be reachable.
Examples
The following example sets the source VTEP IP address of NVE:
Switch# configure terminal
Switch(config)# interface nve 1
Switch(config-if)# source 1.1.1.1
Switch# show interface nve 1
Interface nve1
Interface current state: UP
Index 540673 , Metric 0 , Encapsulation VXLAN
VRF binding: not bound
Tunnel protocol/transport Vxlan, Status Valid
Source 1.2.3.4 (loopback1)
tunnel keep-vlan-tag disable
tunnel split-horizon enable
tunnel encapsulation-dscp-strategy dscp-copy
Vni 10000, protocol type bgp, Inclusive-multi(local) active
Vni 20000, protocol type bgp (associate-vrf), Inclusive-multi(local) inactive
Related Commands
None
17.2.18. member vni
Command Purpose
Use this command to bind the VNI with the NVE.
To unbind the VNI from the NVE, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
member vni (VAL) (associate-vrf| )
no member vni (VAL) (associate-vrf| )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
VAL |
The VNI of value |
1 - 16777215 |
associate-vrf |
The L3 VNI of VRF |
- |
Command Mode
Interface Configuration
Default
None
Usage
The VNI without associate-vrf is L2 VNI and other is L3 VNI.
Examples
The following example configure the L2 VNI for NVE if:
Switch# configure terminal
Switch(config)# interface nve 1
Switch(config-if)# member vni 10000
Switch# show interface nve 1
Interface nve1
Interface current state: UP
Index 540673 , Metric 0 , Encapsulation VXLAN
VRF binding: not bound
Tunnel protocol/transport Vxlan, Status Valid
Source 1.2.3.4 (loopback1)
tunnel keep-vlan-tag disable
tunnel split-horizon enable
tunnel encapsulation-dscp-strategy dscp-copy
Vni 10000, protocol type bgp, Inclusive-multi(local) active
Related Commands
None
17.2.19. dscp-strategy
Command Purpose
Use the command to configure the outer IP DSCP gaining mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
encapsulation-dscp-strategy (dscp-copy|priority-map|custom-assign VALUE)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
dscp-copy |
Copy from inner IP DSCP |
- |
priority-map |
Map from priority of QoS |
- |
VALUE |
Assign DSCP by users |
0 - 63 |
Command Mode
Interface Configuration
Default
dscp-copy
Usage
When DSCP-strategy is set priority-map, please configure QoS.
Examples
The following example sets overlay DSCP-strategy as custom-assign :
Switch# configure terminal
Switch(config)# interface nve 1
Switch(config- if)# encapsulation-dscp-strategy custom-assign 63
Related Commands
None
17.2.20. virtual-mac
Command Purpose
Use the virtual mac command to specify the virtual route mac address of NVE VTEP. Use the no form of this command to remove the virtual mac address of NVE VTEP.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
virtual-mac MAC
no virtual-mac
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
MAC |
The virtual MAC address of remote VTEP of NVE |
HHHH.HHHH.HHHH |
Command Mode
Interface Configuration
Default
None
Usage
The virtual MAC address will be used as the inner MAC address of routes for EVPN firstly.
Examples
The following example sets the NVE remote VTEP with the virtual MAC a.a.a:
Switch# configure terminal
Switch(config)# interface nve 1
Switch(config- if)#virtual-mac a.a.a
Related Commands
None
17.2.21. keep-vlan-tag
Command Purpose
Use the commad to configure the NVE remote VTEP for keep the inner VLAN tag.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
keep-vlan-tag (enable|disable)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
enable |
Enable keep VLAN tag |
- |
disable |
Diable keep VLAN tag |
- |
Command Mode
Interface Configuration
Default
Diable
Usage
None
Examples
The following example enables the remote VTEP keep VLAN tag of NVE:
Switch# configure terminal
Switch(config)# interface nve 1
Switch(config-if)# keep-vlan-tag enable
Related Commands
None
17.2.22. split-horizon
Command Purpose
Use the commad to configure the MVE remote VTEP for split-horizon.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
split-horizon (enable|disable)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
enable |
Enable split-horizon |
- |
disable |
Disable split-horizon |
- |
Command Mode
Interface Configuration
Default
Enable
Usage
None
Examples
The following example disables the split-horizon of overlay tunnel:
Switch# configure terminal
Switch(config)# interface nve 1
Switch(config- if)# split-horizon disable
Related Commands
None
17.2.23. evpn Inclusive multicast
Command Purpose
Use the commad to configure the EVPN Inclusive multicast route whether it can be sent.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
evpn Inclusive multicast (enable|disable)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
enable |
Enable sending Inclusive multicast route |
- |
disable |
Disable sending inclusive multicast route |
- |
Command Mode
Interface Configuration
Default
Enable
Usage
None
Examples
The following example disables the sending Inclusive multicast route by NVE:
Switch# configure terminal
Switch(config)# interface nve 1
Switch(config- if)# evpn Inclusive multicast disable
Related Commands
None
17.2.24. vlan arp-broadcast-suppress
Command Purpose
Use the command to enable the ARP broadcast suppress of VLAN. Use the no form of this command to remove the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
vlan VLAN arp-broadcast-suppress
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
VLAN |
VLAN ID |
2 - 4094 |
Command Mode
VLAN Configuration
Default
disable
Usage
None
Examples
The following example enables ARP broadcast suppress of VLAN 10:
Switch# configure terminal
Switch(config)# vlan database
Switch(config- vlan)# vlan 10 arp-broadcast-suppress enable
Related Commands
None
17.2.25. evpn mode
Command Purpose
Use the command to configure the EVPN mode as asymmetry. Use the no form of this command to remove the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
evpn mode asymmetry
Command Mode
Global Config
Default
Symmetry
Usage
None
Examples
The following example configures the EVPN mode as asymmetry:
Switch# configure terminal
Switch(config)# evpn mode asymmetry
Related Commands
None
17.2.26. vlan mac-address-tunnel learning-disable
Command Purpose
Use the command to diable the inner FDB learning of EVPN tunnel. Use the no form of this command to remove the configuration.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
vlan <2-4094> mac-address-tunnel learning-disable
Command Mode
OVERLAY Configuration
Default
None
Usage
None
Examples
The following example configures the tunnel FDB learning disable for VLAN 10:
Switch# configure terminal
Switch(config)# overlay
Switch(config-overlay)# vlan 10 mac-address-tunnel learning-disable
Related Commands
None
17.2.27. show bgp evpn
Command Purpose
Use this command to display the route information of EVPN.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show bgp evpn (all|rd VAL|vni VAL) (route-type (mac-ip|inclusive-multi|ip-prefix| )| )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
all |
Display all EVPN route |
- |
rd VAL |
Secify the RD to display EVPN route |
Route distinguisher value. ASN:nn or IP:nnASN range is 1-4294967295nn range is 1 - 65535 |
vni VAL |
Secify the VNI to display EVPN route |
1 - 16777215 |
route-type |
Specify the type of EVPN route |
- |
mac-ip |
MAC/IP Advertisement Route |
- |
inclusive-multi |
Inclusive multicast Advertisement Route |
- |
ip-prefix |
IP-prefix Advertisement Route |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the route information of EVPN:
Switch# show bgp evpn all
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:2001 (VNI 2001)
*> [2]:[0]:[48]:[8264.c465.9400]:[32]:[12.12.12.2]/136
1.1.1.1 32768 i
*> [2]:[0]:[48]:[8264.c465.9400]:[32]:[12.12.12.3]/136
1.1.1.1 32768 i
Related Commands
evpn
17.2.28. show bgp evpn instance
Command Purpose
Use this command to display the instance information of EVPN.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show bgp evpn instance (all|vni VAL)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
all |
all EVPN intance |
- |
vni VAL |
Secify the VNI to display EVPN instance |
1 - 16777215 |
Command Mode
Privileged EXEC
Default
none
Usage
None
Examples
The following example shows how to display the information of EVPN instance:
Switch# show bgp evpn instance vni 10000
Swicth# show bgp evpn instance vni 10000
EVPN instance vni : 10000
Address family : evpn
Route Distinguisher: 1:10000(auto)
Route Target Export: assigned
: 1:10000
Route Target Import: assigned
: 1:10000
Route Map Export : -
Route Map Import : -
Related Commands
None
17.2.29. show bgp evpn neighbors
Command Purpose
Use this command to display the neighbor information of EVPN.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show bgp evpn (neighbors IP_ADDR|summary| )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR |
Secify the IP address of neighbor |
IPv4 Address |
summary |
Display the summary information of EVPN neighbors |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the summary information of EVPN neighbors:
Switch# show bgp evpn summary
BGP router identifier 12.12.12.1, local AS number 1
BGP table version is 10
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.2 4 1 946 954 10 0 0 13:35:36 0
Total number of neighbors 1
Related Commands
evpn
17.2.30. show overlay host-information
Command Purpose
Use this command to display the host information.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show overlay host-information (vni VAL|summary)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
vni VAL |
Secify the VNI to display host information |
1 - 16777215 |
summary |
Specify the summary of host information |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the route information of EVPN:
Switch# show overlay host-information vni 2001
Mac IP address VTEP address Tunnel Route
-----------------------------------------------------------
8264.c465.9400 12.12.12.3 1.1.1.1 N N
Related Commands
evpn
17.2.31. show interface nve
Command Purpose
Use this command to display the interface NVE information.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show interface nve INDEX
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INDEX |
The index of NVE if |
0-3 |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the NVE if information:
Switch# show interface nve 1
Interface nve1
Interface current state: UP
Index 540673 , Metric 0 , Encapsulation VXLAN
VRF binding: not bound
Tunnel protocol/transport Vxlan, Status Valid
Source 1.2.3.4 (loopback1)
tunnel keep-vlan-tag disable
tunnel split-horizon enable
tunnel encapsulation-dscp-strategy dscp-copy
Vni 10000, protocol type bgp, Inclusive-multi(local) active
Vni 20000, protocol type bgp (associate-vrf), Inclusive-multi(local) inactive
Related Commands
None
17.2.32. show overlay tunnel
Command Purpose
Use this command to display the overlay tunnel info.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show overlay tunnel (static|evpn|interface nve IFNVE| )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
static |
tunnel of static |
- |
evpn |
tunnel of EVPN |
- |
IFNVE |
The index of NVE if |
0 - 3 |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the overlay tunnel information:
Switch# show overlay tunnel evpn
------------------------------------------------------------------------------
Vlan Vni Type Remote-vtep IP-Address Src-Address Head-end-flooding Protocol
10 10000 VxLAN 0 10.20.30.40 1.2.3.4 Enable Evpn
Related Commands
None
17.2.33. show overlay evpn remote-vtep
Command Purpose
Use this command to display the overlay EVPN VTEP info.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show overlay evpn remote-vtep (interface nve IFNVE)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNVE |
The index of NVE if |
0 - 3 |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the overlay tunnel information:
Switch# show overlay evpn remote-vtep interface nve 1
-----------------------------------------------------------------------------------------------
Nve Vni Src-ip Dst-ip Keep-vlan Split-horizon Dscp-strategy
nve1 10000 1.2.3.4 10.20.30.40 Disable Enable Dscp-copy
Related Commands
None
17.2.34. show overlay mac-forwarding-information
Command Purpose
Use this command to display the remote FDB information.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show overlay mac-forwarding-information (vni VAL|summary)
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
vni VAL |
Secify the VNI to display host information |
1 - 16777215 |
summary |
Specify the summary of host information |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the mac forward information of EVPN:
Switch# show overlay mac-forwarding-information vni 10000
Vlan Mac IP address Tunnel
-----------------------------------------------------------
10 6ae7.f8cb.7700 10.20.30.40 Y
Related Commands
evpn