6.8. ISIS Commands
6.8.1. accept-lifetime
Command Purpose
Use this command to specify the time period during which the authentication on a key chain is received as valid.
Use the no parameter with this command to negate this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
accept-lifetime HH:MM:SS DAY MONTH YEAR HH1:MM1:SS1 DAY1 MONTH1 YEAR1
accept-lifetime HH:MM:SS MONTH DAY YEAR infinite
accept-lifetime HH:MM:SS MONTH DAY YEAR duration <1-2147483646>
no accept-lifetime
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
HH:MM:SS |
Specify the end time of accept-lifetime in hours, minutes and seconds. |
0-23:0-59:0-59 |
DAY |
Specify the day of the month to end. |
1-31 |
MONTH |
Specify the month of the year to end as the first three letters of the month, for example, december. |
january, february, march, april, may, june, july, august, september, october, november, december |
YEAR |
Specify the year to end. |
1993-2035 |
HH1:MM1:SS1 |
0-23:0-59:0-59 |
|
DAY1 |
- |
1-31 |
MONTH1 |
- |
january, february, march, april, may, june, july, august, september, october, november, december |
YEAR1 |
- |
1993-2035 |
<1-2147483646> |
Specify the actual end time duration of a key in seconds. |
1-2147483646 |
Command Mode
Key Chain Configuration
Default
None
Usage
None
Examples
The follow example shows how to specify the time period during which the authentication on a key chain is received as valid.:
Switch# configure terminal
Switch(config)# key chain mychain
Switch(config-keychain)# key 1
Switch(config-keychain-key)# accept-lifetime 03:03:01 Dec 3 2023 04:04:02 Oct 6 2023
6.8.2. address-family ipv6
Command Purpose
Use this command to enter ‘address-family ipv6’ mode, where users can configure IPv6 routing specific configuration.
Use the no parameter with this command to remove all configuration under ‘address-family ipv6’.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
address-family ipv6 ( unicast | )
no address-family ipv6 ( unicast | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
unicast |
Specify unicast routing for IPv6. |
- |
Command Mode
Router Configuration
Default
None
Usage
None
Examples
The following example shows how to to enter ‘address-family ipv6’ mode:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# address-family ipv6 unicast
Switch(config-router-af)#
Related Commands
None
6.8.3. adjacency-check
Command Purpose
Use this command to configure the policy of adjacency based on the protocol related TLVs in the Hello packet. Check adjacency with protocol related TLVs including Protocols Supported TLV or IP Interface Address TLV by default. The command with no parameter disables this check.
Use the no parameter with this command to disable the adjacency check.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
adjacency-check
no adjacency-check
Command Mode
Router Configuration
Address Family Configuration
Default
Enabled
Usage
None
Examples
The following example shows how to to enable adjacency check:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# adjacency-check
Related Commands
None
6.8.4. area-password
Command Purpose
Use this command to set the authentication password for the Level-1 area and to set authentication on Level-1 SNP PDUs. This command enables authentication when receiving and sending LSP and SNP PDU in Level-1 areas. Area password must be the same for all the routers in the same area.
Use the no parameter with this command to clear the area password.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
area-password PASSWORD
area-password WORD authenticate snp ( send-only | validate )
no area-password
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PASSWORD |
Specify the password string. |
Up to 254 characters |
authenticate |
Specify to insert the password into Level-1 SNP PDUs. |
- |
snp |
Specify the sequence number PDU (SNP). |
- |
send-only |
Specify to only insert the password into the Level-1 SNP PDUs, but not check the password in SNP PDUs that it receives. Use this keysword during a software upgrade to ease the transition. |
- |
validate |
Specify to insert the password into the Level-1 SNP PDUs and check the password in SNPs that it receives. |
- |
Command Mode
Router Configuration
Default
Not configured
Usage
None
Examples
The following example shows how to set the authentication password for the Level-1 area:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# area-password code1234
Switch(config-router)# no area-password
Related Commands
None
6.8.5. authentication key-chain
Command Purpose
Use this command to set the key chain to be used for authentication at the instance level. Authentication mode must be set to md5 to configure the key chain. If no key chain is configured with the key-chain command, no key-chain authentication is performed.
Only one authentication key-chain is applied to an interface at a time. That is, issuing a second isis authentication key-chain command overrides the first isis authentication key-chain command. Authentication can be specified for an individual interface using the isis authentication key-chain command.
Use the no parameter with this command to unset the key chain used for authentication.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
authentication key-chain WORD ( level-1 | level-2 | )
no authentication key-chain PASSWORD ( level-1 | level-2 | )
no authentication key-chain ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
WORD |
Specify the chain name (valid authentication keys). |
A String of key chain name |
level-1 |
Specify an authentication key-chain for level-1 PDUs. |
- |
level-2 |
Specify an authentication key-chain for level-2 PDUs. |
- |
Command Mode
Router Configuration
Default
Disabled
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set the key chain to be used for authentication at the level-1:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# authentication key-chain code1234 level-1
Related Commands
None
6.8.6. authentication mode md5
Command Purpose
Use this command to set the MD5 authentication mode at the instance level.
If clear-text authentication was configured using the area-password or domain-password commands, the authentication mode command overrides both of those commands (based on the level at which MD5 is configured). If the authentication mode command was used first, and subsequently an attempt is made to use the area-password or domain-password commands, the attempt fails. To configure clear-text authentication using the area-password or domain-password commands, first use the no authentication mode command.
The type of authentication and the level to which it applies can be specified for a single interface, rather than per instance, using the isis authentication mode command.
Use the no parameter with this command to unset the MD5 authentication mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
authentication mode ( md5 | text ) ( level-1 | level-2 | )
no authentication mode ( md5 | text ) ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
md5 |
Keyed message digest |
- |
text |
Text mode |
- |
level-1 |
Specify an authentication key-chain for level-1 PDUs. |
- |
level-2 |
Specify an authentication key-chain for level-2 PDUs. |
- |
Command Mode
Router Configuration
Default
Disabled
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set the MD5 authentication mode at the level-1:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# authentication mode md5 level-1
Switch(config-router)# no authentication mode md5 level-1
Related Commands
None
6.8.7. authentication send-only
Command Purpose
Use this command to set the send-only option at the instance level.
Use this command before configuring the authentication mode and authentication key-chain, so that the implementation of authentication goes smoothly.
After all routers that must communicate are configured with this command, enable the authentication mode and key chain on each router. Then, specify the no authentication send-only command to disable the send-only feature.
If neither the level-1 nor level-2 keysword is configured, the send-only feature applies to both levels.The send-only option applies to both levels if no level is specified.
Use the no parameter with this command to unset the send-only option.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
authentication send-only ( level-1 | level-2 | )
no authentication send-only ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
level-1 |
Specify an authentication key-chain for level-1 PDUs. |
- |
level-2 |
Specify an authentication key-chain for level-2 PDUs. |
- |
Command Mode
Router Configuration
Default
Disabled
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set the send-only option at the level-1.:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# authentication send-only level-1
Switch(config-router)# no authentication send-only level-1
Related Commands
None
6.8.8. bfd all-interfaces
Command Purpose
Use this command to enable the Bidirectional Forwarding Detection (BFD) feature on the interfaces enabled with this ISIS instance.
This command sets BFD fall-over check for all the neighbors under specified process. To disable BFD checking on particular interface use isis bfd disable command at interface mode.
Use the no parameter with this command to disable BFD functionality for an instance.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
bfd all-interfaces
no bfd all-interfaces
Command Mode
Router Configuration
Default
Disabled
Usage
None
Examples
The following example shows how to enable the BFD feature on the interfaces enabled with this ISIS instance.:
Switch# configure terminal
Switch(config)# router isis
Switch(config-router)# bfd all-interfaces
Related Commands
None
6.8.9. clear clns neighbors
Command Purpose
Use this command to clear CLNS neighbor adjacencies.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
clear clns neighbors
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The example shows how to clear CLNS neighbor adjacencies.:
Switch# clear clns neighbors
Related Commands
None
6.8.10. clear clns is-neighbors
Command Purpose
Use this command to clear IS neighbor adjacencies.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
clear clns is-neighbors System-ID
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
System-ID |
Neighbor system ID in XXXX.XXXX.XXXX format. |
hexadecimal |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The example shows how to clear IS neighbor adjacencies.:
Switch# clear clns is-neighbors 1234.789A.BCDF
Related Commands
None
6.8.11. clear ip isis route
Command Purpose
Use this command to clear IPv4 routes.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
clear ip isis ( INSTANCE | ) route ( redistribution | all )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Routing area tag. |
Up to 20 characters |
redistribution |
Clear ISIS local redistribution routes. |
- |
all |
Clear all of the ISIS routing table.s |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The example shows how to clear ISIS IPv4 routes.:
Switch# clear ip isis route all
Related Commands
None
6.8.12. clear isis counter
Command Purpose
Use this command to clear system-wide IS-IS counters
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
clear isis counter
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The example shows how to clear system-wide IS-IS counters.:
Switch# clear isis counter
Related Commands
None
6.8.13. clear isis interface counter
Command Purpose
Use this command to clear interface counters.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
clear isis interface counter ( IFNAME | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
Interface name. |
Supportphysical/aggregation/loopback/vlan/tunnelports |
Command Mode
Privileged EXEC
Default
None
Usage
If you do not specify a parameter, then counters for all interfaces are cleared.
Examples
The example shows how to clear clear interface counters.:
Switch# clear isis interface counter
Related Commands
None
6.8.14. clear isis process
Command Purpose
Use this command to restart ISIS processes.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
clear isis ( INSTANCE | ) process
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Routing area tag. |
Up to 20 characters |
Command Mode
Privileged EXEC
Default
None
Usage
If you do not specify a parameter, then all ISIS processes are restarted.
Examples
The example shows how to restart ISIS processes.:
Switch# clear isis process
Related Commands
None
6.8.15. debug isis
Command Purpose
Use this command to turn on debugging for specified criteria. Debug commands enable to show some debugging information about specified criteria into file or terminal.
Use the no parameter to turn off debugging for specified criteria.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug isis ( all | )
debug isis ( authentication | bfd | checksum | events | hello ( interface IFNAME | System-ID | ) | ifsm | local-updates | lsp | nfsm | nsm | pdu | protocol-errors | spf )
no debug isis ( all | )
no debug all
no debug all isis
undebug all
undebug isis ( all | )
undebug all isis
no debug isis ( authentication | bfd | checksum | events | hello ( interface IFNAME | System-ID | ) | ifsm | local-updates | lsp | nfsm | nsm | pdu | protocol-errors | spf )
undebug isis ( authentication | bfd | checksum | events | hello ( interface IFNAME | System-ID | ) | ifsm | local-updates | lsp | nfsm | nsm | pdu | protocol-errors | spf )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
all |
Enables all debugging. |
- |
authentication |
Debugging for authentication. |
- |
checksum |
Debugging for checksums. |
- |
bfd |
Debugging for bidirectional forwarding detection. |
- |
events |
Debugging for internal events. |
- |
hello |
Debugging for hello processing. |
- |
interface |
Interface. |
- |
IFNAME |
Interface name. |
Supportphysical/aggregation/loopback/vlan/tunnelports |
System-ID |
System identifier. |
- |
ifsm |
Debugging for interface finite state machine. |
- |
local-updates |
Debugging for local updates. |
- |
lsp |
Debugging for label switched path. |
- |
nfsm |
Debugging for neighbor finite state machine. |
- |
nsm |
Debugging for NSM messages. |
- |
pdu |
Debugging for protocol data unit. |
- |
protocol-errors |
Debugging for protocol errors. |
- |
spf |
Debugging for shortest path first route calculation. |
- |
Command Mode
Privileged EXEC
Default
Disabled
Usage
None
Examples
The example shows how to enable all isis debugging.:
Switch# debug isis all
Related Commands
None
6.8.16. default-information originate
Command Purpose
Use this command to originate reachability information to Default destination into LSP.There is no default information in Level-2 domain by default, while Level-1 router calculates default to L1L2 route SPF calculation. This command enables to originate default route into Level-2 domain.
Use the no parameter with this command to withdraw reachability information to default destination from LSP.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
default-information originate
no default-information originate
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
originate |
Specify to distribute a default route |
- |
Command Mode
Router Configuration
Address Family Configuration
Default
Disabled
Usage
None
Examples
The following example shows how to originate reachability information to Default destination into LSP both ipv4 and ipv6:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# default-information originate
Switch(config-router)# address-family ipv6
Switch(config-router)# default-information originate
Related Commands
None
6.8.17. distance
Command Purpose
Use this command in router mode to set the administrative distance for all IPv4 routes.
Use the no parameter with this command to remove an administrative distance.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
distance DISTANCE ( System-ID ( ACL | ) | )
no distance ( ( System-ID | System-ID ACL ) | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
DISTANCE |
Distance range. |
1-255 |
System-ID |
Source ID in XXXX.XXXX.XXXX format. |
hexadecimal |
ACL |
Access-list name. |
Up to 40 characters |
Command Mode
Router Configuration
Default
None
Usage
None
Examples
The following example shows how to set the administrative distance for all ISIS IPv4 routes:
Switch# configure terminal
Switch(config)# router isis
Switch(config-router)# distance 40
Related Commands
None
6.8.18. domain-password
Command Purpose
Use this command to set the authentication password for the Level-2 domain, and optionally, the authentication password on Level-2 SNP PDUs. Configuring this command to enable authentication when receiving and sending LSP and SNP PDU in Level-2 domain. Domain password must be the same in Level-2 domain.
Use the no parameter with this command to clear the domain password.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
domain-password PASSWORD
domain-password PASSWORD authenticate snp ( send-only | validate )
no domain-password
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PASSWORD |
The password string. |
Up to 254 characters |
authenticate |
Inserts the password into Level-2 SNP PDUs. |
- |
snp |
SNP PDUs. |
- |
send-only |
Only inserts the password into the Level-2 SNP PDUs, but does not check the password in SNP PDUs that it receives. Use this keysword during a software upgrade to ease the transition. |
- |
validate |
Inserts the password into the Level-2 SNP PDUs, and checks the password in SNP PDUs that it receives. |
- |
Command Mode
Router Configuration
Default
By default, there is no domain password.
Usage
None
Examples
The following example shows how to set the authentication password for the Level-2 domain:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# domain-password mypasswd
Switch(config-router)# no domain-password
Related Commands
None
6.8.19. ignore-lsp-errors
Command Purpose
Use this command to ignore LSPs with checksum errors. By default, validates checksum for LSP whenever it receives LSPs and if the checksum has an error, the LSP will be dropped. Configuring this command to ignore the LSP checksum error and treat it as if checksum is passed.
Use the no parameter to turn off this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ignore-lsp-errors
no ignore-lsp-errors
Command Mode
Router Configuration
Default
Disabled
Usage
None
Examples
The following example shows how to ignore LSPs with checksum errors:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# ignore-lsp-errors
Related Commands
None
6.8.20. ip route high-priority tag
Command Purpose
Use this command to set a high priority tag value.
Use the no parameter to turn off this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip route high-priority tag TAG
no ip route high-priority tag
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
TAG |
Tag value |
1-4294967295 |
Command Mode
Router Configuration
Default
Disabled
Usage
None
Examples
The following example shows how to set a high priority tag value.:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# ip route high-priority tag 500
Related Commands
None
6.8.21. ip router isis
Command Purpose
Use this command to enable IPv4 routing on the interface. This command is mandatory to configuration. Match the instance tag to one of existing instance’s tags, or a new instance with the tag name should be initiated, otherwise routing will not run on this interface.
Configuring this command, the router sends Hello with IP address TLV on this interface, and IP reachability information TLV in the LSP will be updated.
Use the no parameter with this command to disable IPv4 routing on the interface. This action does not clear the database. To clear the database, unconfigure the routing instance.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip router isis ( INSTANCE | )
no ip router isis ( INSTANCE | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
instance name. |
Up to 20 characters |
Command Mode
Interface Configuration
Default
Disabled
Usage
None
Examples
The following example shows how to enable ISIS IPv4 routing on the interface:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# ip router isis bb
Related Commands
None
6.8.22. ipv6 router isis
Command Purpose
Use this command to enable IPv6 routing on the interface. This command is mandatory to IPv6 configuration. Match the instance tag to one of existing instance’s tags, or a new instance with the tag name should be initiated, otherwise routing will not run on this interface.
Configuring this command, the router sends Hello with IPv6 address TLV on this interface, and IPv6 reachability information TLV in the LSP will be updated.
Use the no parameter with this command to disable IPv6 routing on the interface.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ipv6 router isis ( INSTANCE | )
no ipv6 router isis ( INSTANCE | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
instance name. |
Up to 20 characters |
Command Mode
Interface Configuration
Default
Disabled
Usage
None
Examples
The following example shows how to enable ISIS IPv6 routing on the interface:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# ipv6 router isis bb
Related Commands
None
6.8.23. isis authentication key-chain
Command Purpose
Use this command to set the key chain to be used for authentication on the interface-related packets.
Authentication mode must be set to md5 or text to configure the key chain. If no key chain is configured with the key-chain command, no key-chain authentication is performed. Only one authentication key-chain is applied to an interface at a time. That is, issuing a second isis authentication key-chain command overrides the first isis authentication key-chain command.
If neither the level-1 nor level-2 keysword is configured, the key chain applies to the level(s) on which the authentication mode is configured as md5. Authentication can be specified for an entire, instead of at the interface level, by using the authentication key-chain command.
Use the no parameter with this command to unset the key chain used for authentication on the interface-related packets.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis authentication key-chain KEY_NAME ( level-1 | level-2 | )
no isis authentication key-chain ( level-1 | level-2 | )
no isis authentication key-chain KEY_NAME ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
KEY_NAME |
Chain name - valid authentication keys. |
A String of key chain name |
level-1 |
Specify an authentication key-chain for level-1 PDUs. |
- |
level-2 |
Specify an authentication key-chain for level-2 PDUs. |
- |
Command Mode
Interface Configuration
Default
Disabled
Usage
The key chain applies to the level(s) on which authentication mode is configured as MD5 if no level is specified.
Examples
The following example shows how to set the key chain to be used for authentication on the interface-related packets:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis authentication key-chain code1234 level-1
Related Commands
None
6.8.24. isis authentication mode md5
Command Purpose
Use this command to set the MD5 authentication mode. If clear text authentication was configured using the isis password command, the isis authentication mode command overrides the isis password command. If the isis authentication mode command was used, then subsequently an attempt is made to use the isis password command, the attempt fails.
To configure clear text authentication using the isis password command, first use the no isis authentication mode command. The type of authentication and the level to which it applies can be specified for the entire instance, rather than per interface, using the authentication mode command.
Use the no parameter with this command to unset the MD5 authentication mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis authentication mode ( md5 | text ) ( level-1 | level-2 | )
no isis authentication mode ( md5 | text ) ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
md5 |
Keyed message digest |
- |
text |
Text mode |
- |
level-1 |
Specify an authentication key-chain for level-1 PDUs. |
- |
level-2 |
Specify an authentication key-chain for level-2 PDUs. |
- |
Command Mode
Interface Configuration
Default
Disabled
Usage
The send-only option applies to both levels if no level is specified.
Examples
The following example shows how to set the MD5 authentication mode.:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis authentication mode md5
Related Commands
None
6.8.25. isis authentication send-only
Command Purpose
Use this command to set the send-only option to the interface-related packets.
Use this command before configuring the ISIS authentication mode and ISIS authentication key-chain, so that the implementation of authentication goes smoothly. That is, the routers will have more time for the keys to be configured on each router if authentication is inserted only on the packets being sent, not checked on packets being received.
After all routers that must communicate are configured with this command, enable the authentication mode and key chain on each router.
Use the no parameter with this command to unset the send-only option to the interface-related packets.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis authentication send-only ( level-1 | level-2 | )
no isis authentication send-only ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
level-1 |
Specify an authentication key-chain for level-1 PDUs. |
- |
level-2 |
Specify an authentication key-chain for level-2 PDUs. |
- |
Command Mode
Interface Configuration
Default
Disabled
Usage
The send-only option applies to both levels if no level is specified.
Examples
The following example shows how to set the send-only option to the interface-related packets.:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis authentication send-only
Related Commands
None
6.8.26. isis bfd
Command Purpose
Use this command to enable/disable the BFD check on interface.
The isis bfd command allows a user to enable BFD on an interface. The isis bfd disable command disables BFD checking on an interface. However, the no isis bfd and no isis bfd disable commands both remove the enable/disable configuration, but do not disable/enable BFD.
The bfd all-interfaces command enables BFD on all interfaces attached to an instance then configuring. This command disables BFD configuration on a particular interface.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis bfd ( disable | )
no isis bfd ( disable | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
disable |
Specify to disable BFD. |
- |
Command Mode
Interface Configuration
Default
Disabled
Usage
None
Examples
The following example shows how to disable bfd on ISIS interface.:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis bfd disable
Related Commands
None
6.8.27. isis circuit-type
Command Purpose
Use this command to set the circuit type for the interface.
If level-1 or level-2-only is specified in this command, sends only the specified level of PDUs.
Use the no parameter to reset circuit type to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis circuit-type ( level-1 | level-1-2 | level-2-only )
no isis circuit-type
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
level-1 |
Specify that only Level-1 adjacencies are formed. |
- |
level-1-2 |
Specify that Level-1-2 adjacencies are formed. |
- |
level-2-only |
Specify that only Level-2 adjacencies are formed. |
- |
Command Mode
Interface Configuration
Default
Eabled level-1 and level-2.
Usage
None
Examples
The following example shows how to set the circuit type for the interface:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis circuit-type level-2-only
Related Commands
None
6.8.28. isis csnp-interval
Command Purpose
Use this command to set CSNP (Complete sequence number PDU) interval in seconds.
Configuring this command changes the interval between two consecutive CSNP transmission. By default, CSNP is sent every 10 seconds only by LAN DIS. This parameter is only valid on broadcast interface, since periodic CSNP is only sent on broadcast interface, while CSNP on Point-to-Point interface is sent only when adjacency is initiated.
Use the no parameter with this command to reset CSNP interval to the default value.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis csnp-interval INTERVAL ( level-1 | level-2 | )
no isis csnp-interval ( level-1 | level-2 | )
no isis csnp-interval <1-65535> ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INTERVAL |
Specify the CSNP interval in seconds. |
1-65535 |
level-1 |
Specify Level-1 CSNP. |
- |
level-2 |
Specify Level-2 CSNP. |
- |
Command Mode
Interface Configuration
Default
10 seconds level-1 and level-2.
Usage
None
Examples
The following example shows how to set CSNP (Complete sequence number PDU) interval.:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis csnp-interval 20
Related Commands
None
6.8.29. isis hello
Command Purpose
Use this command to configure the padding of the Hello packet. pads the Hello packet by default to notify neighbors of the supported MTU size.
Use the no parameter with this command to disable the padding.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis hello padding
no isis hello padding
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
padding |
Specify pad hello packets |
- |
Command Mode
Interface Configuration
Default
By default, pads the Hello packet.
Usage
None
Examples
The following example shows how to configure the padding of the Hello packet.:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis hello padding
Related Commands
None
6.8.30. isis hello-interval
Command Purpose
Use this command to set the Hello interval in seconds. The Hello-interval is set with the hello-multiplier (see isis hello-multiplier command).
Configuring this command changes the time interval between two consecutive Hello transmissions. If a device receives its own LSP with a maximum sequence number, then it suspends for the hold interval. DIS sends Hello transmissions at three times the rate than non-DIS. If is elected as DIS on this interface, sends Hello every 3.3 seconds.
If minimal keysword is specified, Holding timer in Hello PDU is set to 1 second and Hello interval is calculated by dividing by the hello-multiplier. For example, if the hello-multiplier is configured as 4 and hello-interval minimal is the command used, an Hello PDU is sent every 250 milliseconds.
Use the no parameter to set the Hello interval to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis hello-interval INTERVAL ( level-1 | level-2 | )
isis hello-interval minimal ( level-1 | level-2 | )
no isis hello-interval ( level-1 | level-2 | )
no isis hello-interval <1-65535> ( level-1 | level-2 | )
no isis hello-interval minimal ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INTERVAL |
Specify the hello interval in seconds. |
1-65535 |
minimal |
Specify the holding-time as 1 second. |
- |
level-1 |
Specify Level-1 CSNP. |
- |
level-2 |
Specify Level-2 CSNP. |
- |
Command Mode
Interface Configuration
Default
By default, uses 10 seconds for the interval and the interval is applied to both level-1 and level-2.
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set the Hello interval.:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis hello-interval 5 level-1
Related Commands
isis hello-multiplier
6.8.31. isis hello-multiplier
Command Purpose
Use this command to set multiplier for Hello holding time.
Changes Holding Timer in Hello PDU. Holding timer is calculated by “Hello-Interval” multiplied by this value. If minimal keysword is specified with the Hello-Interval, the holding timer is set to 1 second and the hello-interval is calculated by dividing 1 by this value.
Use the no parameter with this command to set multiplier to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis hello-MULTIPLIER <2-100> ( level-1 | level-2 | )
no isis hello-multiplier ( level-1 | level-2 | )
no isis hello-multiplier <2-100> ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
MULTIPLIER |
Specify a hello multiplier value. |
2-100 |
level-1 |
Specify Level-1 hello. |
- |
level-2 |
Specify Level-2 hello. |
- |
Command Mode
Interface Configuration
Default
By default, uses 3 seconds for the multiplier value and the multiplier is applied to both level-1 and level-2.
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set multiplier for Hello holding time:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis hello-multiplier 4
Related Commands
None
6.8.32. isis lsp-interval
Command Purpose
Use this command to set the Link State Packet (LSP) transmission interval.
Configuring this command changes the minimum interval between two consecutive LSP transmission. When flooding or some other event triggers LSP to transmit, the LSP is put on the interface queue and scheduled to transmit according to this interval. Two consecutive LSP transmissions are scheduled to have at least this interval.
Use the no parameter with this command to set LSP transmission interval to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis lsp-interval INTERVAL
no isis lsp-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INTERVAL |
Specify an LSP transmission interval in milliseconds. |
1-4294967295 |
Command Mode
Interface Configuration
Default
By default, 33 milliseconds for the interval.
Usage
None
Examples
The following example shows how to set the Link State Packet (LSP) transmission interval:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis lsp-interval 100
Related Commands
None
6.8.33. isis mesh-group
Command Purpose
Use this command to set Mesh Group ID on the current interface.
Use the no parameter to unset mesh group on the current interface.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis mesh-group MESH_GROUP
isis mesh-group blocked
no isis mesh-group
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
MESH_GROUP |
Specify a mesh group number |
1-4294967295 |
blocked |
Specify to block LSPs on the current interface. If an interface is configured as mesh group blocked, the standard LSP database synchronization process is applied if the interface receives CSNP or PSNP. |
- |
Command Mode
Interface Configuration
Default
By default, mesh groups are not enabled on this interface.
Usage
None
Examples
The following example shows how to set Mesh Group ID on the current interface :
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis mesh-group 20
Related Commands
None
6.8.34. isis metric
Command Purpose
Use this command to set default metric for the interface. The interface default metric is put into IP reachability information TLVs, IS reachability information TLVs and IPv6 reachability TLVs in LSPs. The value is used for SPF calculation.
Use the no parameter with this command to set default metric to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis metric METRIC ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
METRIC |
Specify a default metric. |
1-16777214 |
level-1 |
Specify default metric for level-1 circuit. |
- |
level-2 |
Specify default metric for level-2 circuit. |
- |
Command Mode
Interface Configuration
Default
By default, uses 10 for the metric value and the value is applied to both level-1 and level-2.
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set default metric for the interface:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis metric 20
Related Commands
None
6.8.35. isis network
Command Purpose
Use this command to change a broadcast interface network type to a point-to-point network type.
Use the no parameter with this command to revert to the default setting of a broadcast interface network type.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis network point-to-point
no isis network ( point-to-point | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
point-to-point |
Specify a point-to-point network. |
- |
Command Mode
Interface Configuration
Default
This option is disabled by default.
Usage
None
Examples
The following example shows how to change a broadcast interface network type to a point-to-point network type:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis network point-to-point
Related Commands
None
6.8.36. isis password
Command Purpose
Use this command to set the authentication password of Hello PDU on the interface.
Use the no parameter to clear the password.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis password PASSWORD ( level-1 | level-2 | )
no isis password ( level-1 | level-2 | )
no isis password PASSWORD ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PASSWORD |
Specify a password string. |
Up to 254 characters |
level-1 |
Specify a password for Level-1 hello PDUs. |
- |
level-2 |
Specify a password for Level-2 hello PDUs. |
- |
Command Mode
Interface Configuration
Default
By default, no password is configured; this applies to both level-1 and level-2.
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set the authentication password of Hello PDU on the interface:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis password mypassWORD level-1
Related Commands
None
6.8.37. isis priority
Command Purpose
Use this command to set the priority for LAN DIS election. This command changes the priority value in LAN Hello PDUs. A lower priority value is less preferred in DIS election, and a higher priority value is more preferred.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis priority PRIORITY ( level-1 | level-2 | )
no isis priority ( level-1 | level-2 | )
no isis priority <0-127> ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PRIORITY |
Priority value |
0-127 |
level-1 |
Specify a priority for Level-1 hello PDUs. |
- |
level-2 |
Specify a priority for Level-2 hello PDUs. |
- |
Command Mode
Interface Configuration
Default
By default, uses 64 for the priority value, and the priority is applied to both level-1 and level-2.
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set the priority for LAN DIS election:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis priority 127
Related Commands
None
6.8.38. isis retransmit-interval
Command Purpose
Use this command to set LSP retransmission interval.
Use the no parameter to set the interval to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis retransmit-interval INTERVAL
no isis retransmit-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INTERVAL |
Specify an interval for retransmission of the same LSP in seconds. |
0-65535 |
Command Mode
Interface Configuration
Default
5 seconds.
Usage
None
Examples
The following example shows how to set LSP retransmission interval:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis retransmit-interval 10
Switch(config-if)# no isis retransmit-interval
Related Commands
None
6.8.39. isis tag
Command Purpose
Use this command to set the tag for link-state packets (LSPs) sent out advertising routes for networks directly connected to an interface.
If you do not specify a parameter, then the tag value is set for level-1-2 boundary.
Use the no parameter to unset the tag.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
isis tag TAG ( level-1 | level-2 | )
no isis tag
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
TAG |
Tag value. |
1-4294967295 |
level-1 |
Specify the tag value for the level-1 boundary. |
- |
level-2 |
Specify the tag value for the level-2 boundary. |
- |
Command Mode
Interface Configuration
Default
This option is disabled by default.
Usage
None
Examples
The following example shows how to the tag for link-state packets (LSPs) sent out advertising routes for networks directly connected to an interface.:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# isis tag 500 level-1
Related Commands
None
6.8.40. ispf
Command Purpose
Use this command to enable incremental SPF for a routing process.
Use the no parameter to disable incremental SPF from a routing process.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ispf
ispf ( level-1 | level-1-2 | level-2-only )
no ispf
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
level-1 |
Act as level-1 only IS. |
- |
level-1-2 |
Act as level-1-2 IS. |
- |
level-2-only |
Act as level-2 only IS. |
- |
Command Mode
Router Configuration
Default
None
Usage
None
Examples
The following example shows how to enable incremental SPF for a routing process:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# ispf level-1
Related Commands
None
6.8.41. is-type
Command Purpose
To configure the routing level for an instance of the Intermediate System-to-Intermediate System (IS-IS) routing process, use the is-type command in router configuration mode.
Use the no parameter to set the IS to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
is-type ( level-1 | level-1-2 | level-2-only )
no is-type
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
level-1 |
Act as level-1 only IS. |
- |
level-1-2 |
Act as level-1-2 IS. |
- |
level-2-only |
Act as level-2 only IS. |
- |
Command Mode
Router Configuration
Default
By default, uses level-1-2 if there is no Level-2 instance nor a Level-1-2 instance. Otherwise, it uses level-1.
Usage
None
Examples
The following example shows how to configure the routing level for an ISIS instance:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# is-type level-1
Related Commands
None
6.8.42. lsp-gen-interval
Command Purpose
Use this command to set minimum interval before regenerating the same LSP. The smaller the interval, the faster the convergence. However, this setting might cause more frequent flooding.
Use the no parameter with this command to set the interval to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
lsp-gen-interval INTERVAL
lsp-gen-interval ( level-1 | level-2 ) <1-120>
no lsp-gen-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INTERVAL |
Specify a minimum interval in seconds. |
1-120 |
level-1 |
Specify an interval for Level-1 IS. |
- |
level-2 |
Specify an interval for Level-2 IS. |
- |
Command Mode
Router Configuration
Default
30 seconds for the interval and the interval is applied to both level-1 and level-2.
Usage
None
Examples
The following example shows how to set minimum interval before regenerating the same LSP:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# lsp-gen-interval 5
Related Commands
None
6.8.43. lsp-mtu
Command Purpose
Use this command to set LSP MTU in bytes.
Use the no parameter with this command to set the MTU to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
lsp-mtu ( level-1 | level-2 | ) MTU
no lsp-mtu ( level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
MTU |
Specify an MTU size |
512-1492 |
level-1 |
Specify an interval for Level-1 IS. |
- |
level-2 |
Specify an interval for Level-2 IS. |
- |
Command Mode
Router Configuration
Default
None
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to both levels.
Examples
The following example shows how to set LSP MTU in bytes:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# lsp-mtu 555
Related Commands
None
6.8.44. lsp-refresh-interval
Command Purpose
Use this command to set the LSP refresh interval.
IP Infusion recommends making the lsp-refresh-interval smaller than max-lsp-lifetime value.
Use the no parameter to set the interval to the default value.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
lsp-refresh-interval INTERVAL
no lsp-refresh-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INTERVAL |
Specify an LSP refresh interval in seconds. |
1-65535 |
Command Mode
Router Configuration
Default
900 seconds.
Usage
None
Examples
The following example shows how to set the LSP refresh interval:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# lsp-refresh-interval 600
Switch(config-router)# no lsp-refresh-interval
Related Commands
None
6.8.45. max-area-addresses
Command Purpose
Use this command to configure additional manual addresses for an IS-IS area.
Use the no parameter to disable the manual addresses.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
max-area-addresses NUMBER
no max-area-addresses
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NUMBER |
Specify the maximum area address that can be supported |
3-127 |
Command Mode
Router Configuration
Default
3
Usage
None
Examples
The following example shows how to configure additional manual addresses for an IS-IS area:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# max-area-address 4
Related Commands
None
6.8.46. max-lsp-lifetime
Command Purpose
Use this command to set the maximum LSP lifetime. You must set max-lsp-lifetime greater than lsp-refreshinterval.
Use the no parameter to set the lifetime to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
max-lsp-lifetime LIFETIME
no max-lsp-lifetime
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
LIFETIME |
Specify an maximum LSP lifetime in seconds. |
350-65535 |
Command Mode
Router Configuration
Default
1200 seconds.
Usage
None
Examples
The following example shows how to set the maximum LSP lifetime:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# max-lsp-lifetime 1500
Related Commands
None
6.8.47. metric-style
Command Purpose
Use this command to configure the metric style.
Use the no parameter to set the style to the default style, narrow.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
metric-style ( narrow | wide | transition ) ( level-1 | level-1-2 | level-2 | )
metric-style ( narrow | wide ) transition ( level-1 | level-1-2 | level-2 | )
no metric-style ( narrow | wide | transition ) ( level-1 | level-1-2 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
narrow |
Specify the old style of TLVs with narrow metric. |
- |
wide |
Specify the new style of TLVs to carry wider metric. |
- |
transition |
Accept both styles of TLVs during transition |
- |
level-1 |
Specify the level-1 metric style. |
- |
level-2 |
Specify the level-2 metric style. |
- |
level-1-2 |
Specify the level-1-2 metric style. |
- |
Command Mode
Router Configuration
Default
By default, uses narrow metric style for level 1 and 2.
Usage
None
Examples
The following example shows how to configure the metric style:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# metric-style wide
Related Commands
None
6.8.48. net
Command Purpose
Use this command to configure an Intermediate System-to-Intermediate System (IS-IS) network entity title (NET) for the routing process, use the net command in router configuration mode. To remove a NET, use the no form of this command.
Use the no parameter to remove the NET.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
net NET
no net NET
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NET |
Specify a network entity title (NET) in 1 to 13 octets |
In XX.XXXX. … .XXXX.XX format |
Command Mode
Router Configuration
Default
By default, does not configure a NET and routing is not enabled for the interface.
Usage
None
Examples
The following example shows how to configure an Intermediate System-to-Intermediate System (IS-IS) network entity title (NET) for the routing process:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# net 49.0000.0001.0002.0003.00
Related Commands
None
6.8.49. passive-interface
Command Purpose
Use this command to suppress routing updates on all interfaces or on a specified interface, which puts the interfaces into passive mode. To advertise passive prefixes in LSP, there is no need to have at an interface configured with ip router isis. Enabling passive interface on an ISIS enabled interface disables ISIS on the interface and makes the interface passive.
Use the no parameter with this command to remove interfaces from passive mode
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
passive-interface ( IFNAME | )
no passive-interface ( IFNAME | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
Indicates an interface name. |
Supportphysical/aggregation/loopback/vlan/tunnelports |
Command Mode
Router Configuration
Default
None
Usage
None
Examples
The following example shows how to suppress routing updates on a specified interface:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# passive-interface eth-0-1
Related Commands
None
6.8.50. prc-interval-exp
Command Purpose
Use this command to configure exponential back-off delay between PRC calculations.
Use the no parameter to disable any set exponential back-off delay between PRC calculations.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
prc-interval-exp
prc-interval-exp EXP_MIN EXP_MAX
no prc-interval-exp
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
EXP_MIN |
Set the minimum delay between receiving a change to PRC calculation in milliseconds. |
0-2147483647 |
EXP_MAX |
Set the maximum delay between receiving a change to PRC calculation in milliseconds. |
0-2147483647 |
Command Mode
Router Configuration
Default
Minimum Delay 500ms, Maximum Delay 50000ms
Usage
None
Examples
The following example shows how to configure exponential back-off delay between PRC calculations:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# prc-interval-exp 100 10000
Related Commands
None
6.8.51. redistribute
Command Purpose
Use this command to redistribute routes from another protocol into the ISIS routing table.
Use the no parameter to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
redistribute ( connected | static | rip | ospf | bgp ) { metric METRIC | metrictype ( internal | external ) | level-1 | level-2 | level-1-2 | route-map ROUTE_MAP }
no redistribute ( connected | static | rip | ospf | bgp )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
connected |
Redistribute connected routes. |
- |
static |
Redistribute static routes. |
- |
rip |
Redistribute RIP routes. |
- |
ospf |
Redistribute OSPF routes. |
- |
bgp |
Redistribute BGP routes. |
- |
metric |
Specify the metric for redistributed routes. |
- |
METRIC |
Specify the IS-IS default metric. |
0-4261412864 |
metric-type |
Specify the IS-IS exterior metric type for redistributed routes: |
- |
internal |
Set IS-IS internal metric type. |
- |
external |
Set IS-IS external metric type. |
- |
level-1 |
IS-IS Level-1 routes. |
- |
level-2 |
IS-IS Level-2 routes. |
- |
level-1-2 |
IS-IS Level-1 and Level-2 routes. |
- |
route-map |
Specify a Route map reference. |
- |
ROUTE_MAP |
Specify name of the route-map. |
Up to 20 characters |
Command Mode
Router Configuration
Default
None
Usage
None
Examples
The following example shows how to redistribute routes from another protocol into the ISIS routing table:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# redistribute bgp metric 12
Related Commands
None
6.8.52. redistribute isis
Command Purpose
Use this command to redistribute reachability information from one level to the other level. If an distribute-list name is given with this command for an access list that does not exist, the routes are still redistributed.
Use the no parameter with this command to stop redistribution.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
redistribute isis level-1 into level-2
redistribute isis level-2 into level-1
redistribute isis level-1 into level-2 distribute-list ACL
redistribute isis level-2 into level-1 distribute-list ACL
no redistribute isis level-1 into level-2
no redistribute isis level-2 into level-1
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
level-1 |
Specify an inter-area route level-1. |
- |
level-2 |
Specify an inter-area routes level-2. |
- |
into |
Specify a from level-n level into level-m. |
- |
distribute-list |
Indicate the distributed-list parameter. |
- |
ACL |
Access-list name |
Up to 40 characters |
Command Mode
Router Configuration
Address Family Configuration
Default
By default, redistributes selected level-1 routes into level-2
Usage
None
Examples
The following example shows how to redistributes level-2 routes into level-1:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# redistribute isis level-2 into level-1
Related Commands
None
6.8.53. router isis
Command Purpose
Use this command in Global Config mode to enable the Intermediate System-to-Intermediate System (IS-IS) routing protocol and to specify an IS-IS process. To disable IS-IS routing, use the noform of this command.
Use the no parameter with this command to disable IS-IS routing.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
router isis ( INSTANCE | )
no router isis ( INSTANCE | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Specify an ISO routing instance tag. |
Up to 20 characters |
Command Mode
Global Config
Default
None
Usage
None
Examples
The following example shows how to set ISIS instance name and create it:
Switch# configure terminal
Switch(config)# router isis 1
Related Commands
None
6.8.54. set-overload-bit
Command Purpose
To configure the router to signal other routers not to use it as an intermediate hop in their shortest path first
(SPF) calculations, use the set-overload-bit command in router configuration mode. To remove the designation,
use the noform of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
set-overload-bit ( { suppress ( external | interlevel | external interlevel | interlevel external ) | on-startup ( TIME | wait-for-bgp ) } | )
no set-overload-bit
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
suppress |
Specify to suppress specific types of IP prefixes. |
- |
external |
Specify to redistribute external reachability (to prevent the IP prefixes learned from other protocols from being advertised). |
- |
interlevel |
Specify to redistribute interlevel reachability. |
- |
on-startup |
Specify an interval in seconds after which the overload state is exited. |
- |
TIME |
Specify the time in seconds to advertise one self as overloaded after reboot. |
5-86400 |
wait-for-bgp |
Specify that BGP determines when to unset the overload bit. |
- |
Command Mode
Router Configuration
Default
By default, no overload-bit is set.
Usage
None
Examples
The following example shows how to set overload bit:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# set-overload-bit
Related Commands
None
6.8.55. spf-interval-exp
Command Purpose
Use this command to set the minimum and maximum hold intervals between Shortest Path First (SPF) calculations.
The spf-interval-exp command configures the minimum and maximum interval time between the receipt of a topology change and the calculation of the SPF.
Use the no parameter with this command to set the minimum and maximum hold intervals to the default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
spf-interval-exp EXP_MIN EXP_MAX
spf-interval-exp ( level-1 | level-2 ) <0-2147483647> <0-2147483647>
no spf-interval-exp
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
EXP_MIN |
Specify the minimum delay between receiving a change to the SPF calculation in milliseconds. |
0-2147483647 |
EXP_MAX |
Specify the maximum delay between receiving a change to the SPF calculation in milliseconds. |
0-2147483647 |
level-1 |
Specify an interval for Level-1 IS. |
- |
level-2 |
Specify an interval for Level-2 IS. |
- |
Command Mode
Router Configuration
Default
By default, uses 500 milliseconds and 50,000 milliseconds for the minimum and maximum hold intervals, respectively. The values are applied to both level-1 and level-2 if the level parameter is omitted.
Usage
None
Examples
The following example shows how to set the minimum and maximum hold intervals between Shortest Path First (SPF) calculations:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# spf-interval-exp level-1 600 60000
Switch(config-router)# no spf-interval-exp level-1
Related Commands
None
6.8.56. summary-address
Command Purpose
Use this command to configure Summary Address to summarize IPv4 reachability information.
Use the no parameter with this command to unconfigure the summary.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
summary-address IP_ADDR/IP_MASK_LEN ( level-1 | level-1-2 | level-2 | ) ( metric ) ( METRIC | )
no summary-address IP_ADDR/IP_MASK_LEN
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR/IP_MASK_LEN |
Specify the IPv4 prefix to be announced. |
IPv4 Address and mask length in A.B.C.D/M format |
level-1 |
Specify the reachability information only for Level-1. |
- |
level-1-2 |
Specify the reachability information for both Level-1 and Level-2. |
- |
level-2 |
Specify the reachability information only for Level-2. |
- |
metric |
Specify the metric for the summarized address. |
- |
METRIC |
Specify the metric. The default is 0. |
1-4294967295 |
Command Mode
Router Configuration
Default
By default, does not configure the summary-address. Summary-address is applied to Level-2 IS if level parameter is omitted.
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to level-2
Examples
The following example shows how to configure ipv4 Summary Address:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# summary-address 10.10.0.0/16
Related Commands
None
6.8.57. summary-prefix
Command Purpose
Use this command to configure the summary prefix to summarize IPv6 reachability information.
Use the no parameter to unconfigure the summary.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
summary-prefix GLOBAL_PREFIX/IPV6_MASK_LEN ( level-1 | level-1-2 | level-2 | ) ( metric METRIC )
no summary-prefix GLOBAL_PREFIX/IPV6_MASK_LEN
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
- GLOBAL _PREFIX/IPV6_MASK_LEN |
Specify the IPv6 prefix to be announced. |
IPv4 Address and mask length in X:X::X:X/M format |
level-1 |
Specify the reachability information only for Level-1. |
- |
level-1-2 |
Specify the reachability information for both Level-1 and Level-2. |
- |
level-2 |
Specify the reachability information only for Level-2. |
- |
metric |
Specify the metric for the summarized address. |
- |
METRIC |
Specify the metric. The default is 0. |
1-4294967295 |
Command Mode
Address Family Configuration
Default
By default, does not configure the summary-prefix. Summary-prefix is applied to Level-2 IS if level parameter is omitted.
Usage
If neither the level-1 nor the level-2 keysword is configured, it applies to level-2
Examples
The following example shows how to configure ipv6 Summary Prefix:
Switch# configure terminal
Switch(config)# router isis 1
Switch(config-router)# address-family ipv6
Switch(config-router)# summary-prefix 3ffe:1234::/32
Related Commands
None
6.8.58. show clns is-neighbors
Command Purpose
Use this command to display all IS neighbor adjacencies.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show clns is-neighbors ( detail | )
show clns INSTANCE is-neighbors ( detail | )
show clns is-neighbors IFNAME ( detail | )
show clns INSTANCE is-neighbors IFNAME ( detail | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Display information for specified instance. |
Up to 20 characters |
IFNAME |
Display information about a single interface. |
Supportphysical/aggregation/loopback/vlan/tunnelports |
detail |
Display detailed information for all interfaces. |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display all IS neighbor adjacencies:
Switch# show clns is-neighbors
Area 100:
System Id Interface State Type Priority Circuit Id
0000.0000.0002 vlan100 Up L2 64 0000.0000.0001.01
0000.0000.0002 vlan200 Up L2 64 0000.0000.0001.02
Related Commands
None
6.8.59. show debugging isis
Command Purpose
Use this command to display the status of the debugging of the ISIS system.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show debugging isis
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the status of the debugging of the ISIS system:
Switch# show debugging isis
IS-IS debugging status:
IS-IS spf debugging is on
Related Commands
None
6.8.60. show ip isis route
Command Purpose
Use this command to display IS-IS routing table for IPv4.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip isis ( INSTANCE | ) route
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Display information for specified instance. |
Supportphysical/aggregation/loopback/vlan/tunnelports |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display IS-IS routing table for IPv4.:
Switch# show ip isis route
Related Commands
None
6.8.61. show ipv6 isis route
Command Purpose
Use this command to display the IS-IS routing table for IPv6.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ipv6 isis ( INSTANCE | ) route
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Display information for specified instance. |
Up to 20 characters |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display IS-IS routing table for IPv6.:
Switch# show ipv6 isis route
Related Commands
None
6.8.62. show ipv6 isis topology
Command Purpose
Use this command to display the IS-IS topology for IPv6.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ipv6 isis topology ( l1 | l2 | level-1 | level-2 | )
show ipv6 isis INSTANCE topology ( l1 | l2 | level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Display information for specified instance. |
Up to 20 characters |
l1 |
IS-IS level-1 SPF topology. |
- |
l2 |
IS-IS level-2 SPF topology. |
- |
level-1 |
IS-IS level-1 SPF topology. |
- |
level-2 |
IS-IS level-2 SPF topology. |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the IS-IS topology for IPv6:
Switch# show ipv6 isis topology
Related Commands
None
6.8.63. show ipv6 protocols isis
Command Purpose
Use this command to display IPv6 process parameters and statistics.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ipv6 protocols isis
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display IPv6 process parameters and statistics.:
Switch# show ipv6 protocols isis
Routing Protocol is "isis 2 "
Redistributing:
Area Address(es):
Distance : (default is 115)
Routing Protocol is "isis 1 "
Redistributing:
Area Address(es):
Distance : (default is 115)
Related Commands
None
6.8.64. show isis counter
Command Purpose
Use this command to display the IS-IS system counter entry MIBs.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show isis counter
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the IS-IS system counter entry MIBs.:
Switch# show isis counter
Area b:
IS-IS Level-1 isisSystemCounterEntry:
isisSysStatCorrLSPs: 0
isisSysStatAuthTypeFails: 0
isisSysStatAuthFails: 0
isisSysStatLSPDbaseOloads: 0
isisSysStatManAddrDropFromAreas: 0
isisSysStatAttmptToExMaxSeqNums: 0
isisSysStatSeqNumSkips: 0
isisSysStatOwnLSPPurges: 0
isisSysStatIDFieldLenMismatches: 0
isisSysStatMaxAreaAddrMismatches: 0
isisSysStatPartChanges: 0
isisSysStatSPFRuns: 0
isisSysStatPRCRuns: 0
Area bb:
IS-IS Level-1 isisSystemCounterEntry:
isisSysStatCorrLSPs: 0
isisSysStatAuthTypeFails: 0
isisSysStatAuthFails: 0
isisSysStatLSPDbaseOloads: 0
isisSysStatManAddrDropFromAreas: 0
isisSysStatAttmptToExMaxSeqNums: 0
isisSysStatSeqNumSkips: 0
isisSysStatOwnLSPPurges: 0
isisSysStatIDFieldLenMismatches: 0
isisSysStatMaxAreaAddrMismatches: 0
isisSysStatPartChanges: 0
isisSysStatSPFRuns: 0
isisSysStatPRCRuns: 0
IS-IS Level-2 isisSystemCounterEntry:
isisSysStatCorrLSPs: 0
isisSysStatAuthTypeFails: 0
isisSysStatAuthFails: 0
isisSysStatLSPDbaseOloads: 0
isisSysStatManAddrDropFromAreas: 0
isisSysStatAttmptToExMaxSeqNums: 0
isisSysStatSeqNumSkips: 0
isisSysStatOwnLSPPurges: 0
isisSysStatIDFieldLenMismatches: 0
isisSysStatMaxAreaAddrMismatches: 0
isisSysStatPartChanges: 0
isisSysStatSPFRuns: 0
isisSysStatPRCRuns: 0
Related Commands
None
6.8.65. show isis database
Command Purpose
Use this command to display detailed link state database information.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show isis database
show isis database ( l1 | l2 | level-1 | level-2 ) LSPID ( detail | verbose )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
detail |
IS-IS link state database detailed information. |
- |
verbose |
IS-IS link state database detailed information. |
- |
LSPID |
LSPID in the form ofXXXX.XXXX.XXXX.XX-XX. |
- |
l1 |
IS-IS level-1 link state database. |
- |
l2 |
IS-IS level-2 link state database. |
- |
level-1 |
IS-IS level-1 link state database. |
- |
level-2 |
IS-IS level-2 link state database. |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display detailed link state database information.:
Switch# show isis database verbose
Area (null):
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00* 0x00000002 0x9E50 1140 0/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00* 0x00000003 0x9C51 1176 0/0/0
Related Commands
None
6.8.66. show isis interface
Command Purpose
Use this command to display detailed interface information.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show isis interface
show isis interface IFNAME
show isis interface counter
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
Display the name of interface. |
Supportphysical/aggregation/loopback/vlan/tunnelports |
counter |
Display the interface counters. |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display detailed interface information about ISIS:
Switch# show isis interface eth-0-1
eth-0-1 is up, line protocol is up
Routing Protocol: IS-IS ((null))
Network Type: Broadcast
Circuit Type: level-1-2
Local circuit ID: 0x01
Extended Local circuit ID: 0x00000001
Local SNPA: e6f5.41de.3200
IP interface address:
1.1.1.1/24
IPv6 interface address:
Level-1 Metric: 10/10, Priority: 64, Circuit ID: 0000.0000.0001.01
Number of active level-1 adjacencies: 0
Level-1 LSP MTU: 1492
Level-2 Metric: 10/10, Priority: 64, Circuit ID: 0000.0000.0001.01
Number of active level-2 adjacencies: 0
Level-2 LSP MTU: 1492
Next IS-IS LAN Level-1 Hello in 238 milliseconds
Next IS-IS LAN Level-2 Hello in 238 milliseconds
Related Commands
None
6.8.67. show isis topology
Command Purpose
Use this command to display data about IS-IS topology.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show isis topology ( l1 | l2 | level-1 | level-2 | )
show isis INSTANCE topology ( l1 | l2 | level-1 | level-2 | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INSTANCE |
Display information for specified instance. |
Up to 20 characters |
l1 |
Display the path to all level-1 routers in the area. |
- |
l2 |
Display the path to all level-2 routers in the domain. |
- |
level-1 |
Display the path to all level-1 routers in the area. |
- |
level-2 |
Display the path to all level-2 routers in the domain. |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display data about IS-IS topology.:
Switch# show isis topology
Related Commands
None
6.8.68. show running-config interface isis
Command Purpose
Use this command to display the ISIS interface configurations.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show running-config interface IFNAME isis
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
Display the name of interface. |
Supportphysical/aggregation/loopback/vlan/tunnelports |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display the ISIS interface configurations.:
Switch# show running-config interface eth-0-1 isis
Building configuration... !
interface eth-0-1
ip router isis !
Related Commands
None
6.8.69. show running-config router isis
Command Purpose
Use this command to display router ISIS configurations.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show running-config router isis
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to display router ISIS configurations.:
Switch# show running-config router isis
Building configuration... !
router isis
net 10.0000.0000.0001.00 !
Related Commands
None