6.2. RIP Commands
6.2.1. default-information originate (RIP)
Command Purpose
To generate a default route into Routing Information Protocol (RIP), use the default-information originate command in router configuration mode. To disable this feature, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
default-information originate ( route-map | )
no default-information originate ( route-map | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
route-map |
Route map reference |
- |
Command Mode
Router Configuration
Default
None
Usage
The route orginated will only be learned by RIP neighbor, and this route is not configured in FIB.
Examples
The following example originates a default route:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# version 2
Switch(config-router)# network 192.168.16.0/24
Switch(config-router)# default-information originate
6.2.2. default-metric (RIP)
Command Purpose
To set default metric values for Routing Information Protocol (RIP), use the default-metric command in router configuration mode. To return to the default state, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
default-metric NUMBER-VALUE
no default-metric
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NUMBER-VALUE |
Default metric value |
1-16 |
Command Mode
Router Configuration
Default
By default, the metric is set to 0.
Usage
The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.
Examples
The following example shows a switch using both the RIP and the Open Shortest Path First (OSPF) routing protocols. The example advertises OSPF-derived routes using RIP and assigns the OSPF-derived routes a RIP metric of 10:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# default-metric 10
Switch(config-router)# redistribute ospf
Related Commands
redistribute (RIP)
6.2.3. distance (RIP)
Command Purpose
To define an administrative distance for routes that are inserted into the routing table, use the distance command in router configuration mode. To return the administrative distance to its default distance definition, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
distance DISTANCE PREFIX/PREFIX-LENGTH ( ACCESSS-LIST-NAME | )
no distance
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
DISTANCE |
Administrative distance |
Administrative distance, an integer from 1 to 255 (routes with a distance value of 255 are not installed in the routing table) |
PREFIX |
IP prefix for the originator of the imcoming routing updates |
IPv4 Address |
PREFIX-LENGTH |
Prefix length for the originator |
1-32 |
ACCESSS-LIST-NAME |
(Optional) Named access list to be applied to incoming routing updates |
Up to 40 characters |
Command Mode
Router Configuration
Default
By default, the distance is 120.
Usage
An administrative distance is a rating of the trustworthiness of a routing information source, such as an individual switch or a group of switches. Numerically, an administrative distance is an integer from 0 to 255. In general, the higher the value, the lower the trust rating. An administrative distance of 255 means the routing information source cannot be trusted at all and should be ignored.
When this command is configured, it is applied when a network is being inserted into the routing table. It filters routing updates according to the IP address of the switch that supplies the routing information. It could be used, for example, to filter possibly incorrect routing information from switches that are not under your administrative control. The optional access list name is used to filter router entries in routing update.
Examples
The following example set administrative distance 200 for routes that are inserted from 20.20.0.0 network segment :
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# network 10.10.0.0/24
Switch(config-router)# network 20.20.0.0/24
Switch(config-router)# distance 200 20.20.0.0/24
Related Commands
distance (OSPF)
6.2.4. ip rip authentication
Command Purpose
To enable authentication for Routing Information Protocol (RIP) Version 2 packets and to specify the set of keys that can be used on an interface, use the ip rip authentication command in interface configuration mode. To prevent authentication, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip rip authentication ( key-chain NAME-OF-CHAIN | string STRING )
no ip rip authentication ( key-chain | string )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
key-chain NAME-OF-CHAIN |
Enables authentication and specifies the group of keys that are valid |
A String of key chain name |
string STRING |
Enables authentication and specifies the authentication string |
Up to 16 characters |
Command Mode
Interface Configuration
Default
No authentication is provided for RIP packets.
Usage
If neither key chain is configured with the key-chain command nor string is configured with the authentication string command, no authentication is performed on the interface (not even the default authentication). Key chain and authentication string can not be configured on the same interface. If you want configure one, make sure the other is not configured.
Examples
The following example configures the interface to accept and send any key belonging to the key chain named trees:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip rip authentication key-chain trees
Related Commands
ip rip authentication mode
6.2.5. ip rip authentication mode
Command Purpose
To specify the type of authentication used in Routing Information Protocol (RIP) Version 2 packets, use the ip rip authentication mode command in interface configuration mode. To restore clear text authentication, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip rip authentication mode ( text | md5 )
no ip rip authentication mode
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
text |
Normal text authentication |
- |
md5 |
Keyed Message Digest 5 (MD5) authentication |
- |
Command Mode
Interface Configuration
Default
Clear text authentication is provided for RIP packets.
Usage
RIP Version 1 does not support authentication.
Examples
The following example configures the interface to use MD5 authentication:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip rip authentication mode md5
Related Commands
ip rip authentication key-chain
6.2.6. ip rip receive version
Command Purpose
To specify a Routing Information Protocol (RIP) version to receive on an interface basis, use the ip rip receive version command in interface configuration mode. To follow the global version rules, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip rip receive version [ 1 | 2 ]
no ip rip receive version
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
1 |
(Optional) Accepts only RIP Version 1 packets on the interface |
- |
2 |
(Optional) Accepts only RIP Version 2 packets on the interface |
- |
Command Mode
Interface Configuration
Default
Only RIPv2 packet should be received.
Usage
Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured. You can configure the interface to accept both RIP versions.
Examples
The following example configures the interface to receive both RIP Version 1 and Version 2 packets:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip rip receive version 1 2
Related Commands
version (RIP)
6.2.7. ip rip receive-packet
Command Purpose
To enable the interface to receive Routing Information Protocol (RIP) packets, use the ip rip receive-packet command in interface configuration mode. To disable to receive RIP packets, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip rip receive-packet
no ip rip receive-packet
Command Mode
Interface Configuration
Default
Receive packet is enabled by default.
Usage
Use this command to enable or disable the capability of receiving RIP packets, whether the network of this interface is added into RIP or not.
Examples
The following example enables the reception of RIP packets:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip rip receive-packet
Related Commands
ip rip receive version
6.2.8. ip rip send version
Command Purpose
To specify a Routing Information Protocol (RIP) version to send on an interface basis, use the ip rip send version command in interface configuration mode. To follow the global version rules, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip rip send version ( ( [ 1 | 2 ] ) | 1-compatible )
no ip rip send version
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
1 |
(Optional) Sends only RIP Version 1 packets out the interface |
- |
2 |
(Optional) Sends only RIP Version 2 packets out the interface |
- |
1-compatible |
(Optional) Sends RIP Version 2 packets out the interface with broadcast IP address |
- |
Command Mode
Interface Configuration
Default
Only RIPv2 packet should be send.
Usage
Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured. You can configure the interface to send both RIP versions.
Examples
The following example configures the interface to send both RIP Version 1 and Version 2 packets:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip rip send version 1 2
Related Commands
ip rip receive version
6.2.9. ip rip send-packet
Command Purpose
To enable the interface to send Routing Information Protocol (RIP) packets, use the ip rip send-packet command in interface configuration mode. To disable to send RIP packets, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip rip send-packet
no ip rip send-packet
Command Mode
Interface Configuration
Default
Send packet is enabled by default.
Usage
Use this command to enable or disable the capability of sending RIP packets, whether the network of this interface is added into RIP or not.
Examples
The following example enables the transmission of RIP packets:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip rip send-packet
Related Commands
ip rip send version
6.2.10. ip rip split-horizon
Command Purpose
To enable the split horizon mechanism for Routing Information Protocol (RIP), use the ip rip split-horizon command in interface configuration mode. To disable the split horizon mechanism, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip rip split-horizon ( poisoned | )
no ip rip split-horizon
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
poisoned |
Split horizon with poisoned reverse |
- |
Command Mode
Interface Configuration
Default
This command is enabled with poisoned reverse by default.
Usage
In general, changing the state of the default for the ip rip split-horizon command is not recommended, unless you are certain that your application requires a change in order to properly advertise routes.
Examples
The following example enables split horizon without poisoned reverse:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip rip split-horizon
Related Commands
None
6.2.11. network (RIP)
Command Purpose
To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. To remove an entry, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
network ( PREFIX / PREFIX-LENGTH )
no network ( PREFIX / PREFIX-LENGTH )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PREFIX |
IP route prefix for the network |
IPv4 Address |
PREFIX-LENGTH |
Prefix length for the network |
1-32 |
Command Mode
Router Configuration
Default
No networks are specified.
Usage
There is no limit to the number of network commands you can use on the switch. RIP routing updates will be sent and received only through interfaces on this network.
RIP sends updates to the interfaces in the specified networks. Also, if the network of an interface is not specified, the interface will not be advertised in any RIP update.
Examples
The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 10.99.0.0/16 and 192.168.7.0/24:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# network 10.99.0.0/16
Switch(config-router)# network 192.168.7.0/24
Related Commands
router rip
6.2.12. neighbor (RIP)
Command Purpose
To define a neighboring switch with which to exchange routing information, use the neighbor command in router configuration mode. To remove an entry, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
neighbor IP-ADDRESS
no neighbor IP-ADDRESS
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP-ADDRESS |
IP address of a peer switch with which routing information will be exchanged |
IPv4 Address |
Command Mode
Router Configuration
Default
No neighboring switches are defined.
Usage
This command permits the point-to-point (non-broadcast) exchange of routing information. When it is used in combination with the passive-interface router configuration command, routing information can be exchanged between a subset of switches and access servers on a LAN.
Multiple neighbor commands can be used to specify additional neighbors or peers.
Examples
In the following example, RIP updates are sent to all interfaces on network 10.108.0.0 except eth-0-1. However, in this case a neighbor switch configuration command is included. This command permits the sending of routing updates to specific neighbors. One copy of the routing update is generated per neighbor:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# network 10.108.0.0/16
Switch(config-router)# passive-interface eth-0-1
Switch(config-router)# neighbor 10.108.20.4
Related Commands
router rip
6.2.13. offset-list (RIP)
Command Purpose
To add an offset to incoming and outgoing metrics to routes learned via Routing Information Protocol (RIP), use the offset-list command in router configuration mode. To remove an offset list, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
offset-list ACCESSS-LIST-NAME ( in | out ) METRIC-OFFSET ( IFNAME| )
no offset-list ( in | out ) ( IFNAME | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
ACCESSS-LIST-NAME |
Named access list to be applied |
Up to 40 characters |
in |
Applies the access list to incoming metrics |
- |
out |
Applies the access list to outgoing metrics |
- |
METRIC-OFFSET |
Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken |
0-16 |
IFNAME |
Interface name to which the offset list is applied |
Supportphysical/aggregation/loopback/vlan/tunnelports |
Command Mode
Router Configuration
Default
This command is disabled by default.
Usage
The offset value is added to the routing metric. An offset list with an interface is considered extended and takes precedence over an offset list that is not extended. Therefore, if an entry passes the extended offset list and the normal offset list, the offset of the extended offset list is added to the metric.
Examples
In the following example, the switch applies an offset to the delay component of a switch only to access list 21:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# offset-list 21 out 10
Related Commands
None
6.2.14. passive-interface (RIP)
Command Purpose
To disable sending routing updates for the Routing Information Protocol (RIP) on an interface, use the passive-interface command in router configuration mode. To re-enable the sending of routing updates, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
passive-interface IFNAME
no passive-interface IFNAME
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
The interface name |
Supportphysical/aggregation/loopback/vlan/tunnelports |
Command Mode
Router Configuration
Default
Routing updates are sent on the interface.
Usage
If you disable the sending of routing updates on an interface, the particular subnet will continue to be advertised to other interfaces, and updates from other switches on that interface continue to be received and processed.
Examples
The following example sets the interface eth-0-1 as passive:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# network 10.108.0.0/16
Switch(config-router)# passive-interface eth-0-1
Related Commands
router rip
6.2.15. redistribute (RIP)
Command Purpose
To redistribute routes from one routing domain into RIP routing domain, use the redistribute command in router configuration mode. To disable redistribution, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
redistribute PROTOCOL { [ metric VALUE ] | route-map WORD }
no redistribute PROTOCOL
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PROTOCOL |
(Optional) The name of a routing protocol, or the keyword connected, or static. If you specify a routing protocol, use one of the following keywords: bgp, and ospf, connected,isis |
- bgp/ospf/conne cted/isis/static/isis |
metric VALUE |
(Optional) When redistributing other routing process to the RIP process, the default metric is 0 if no metric value is specified |
1-16 |
route-map |
Route map reference |
- |
WORD |
Pointer to route-map entries |
Up to 20 characters |
Command Mode
Router Configuration
Default
Route redistribution is disabled.
Metric metric-value: 0
Usage
The metric value specified in the redistribute command supersedes the metric value specified using the default-metric command.
Examples
The following examples redistribute the static routes into RIP with metric 10:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# network 10.108.0.0/16
Switch(config-router)# redistribute static metric 10
Related Commands
default-metric
6.2.16. router rip
Command Purpose
To configure the Routing Information Protocol (RIP) routing process, use the router rip command in Global Config mode. To turn off the RIP routing process, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
router rip
no router rip
Command Mode
Global Config
Default
None
Usage
None
Examples
The following example shows how to enter the RIP routing configuration:
Switch# configure terminal
Switch(config)# router rip
Related Commands
network (RIP)
6.2.17. timers basic (RIP)
Command Purpose
To adjust Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To restore the default timers, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
timers basic UPDATE TIMEOUT INVALID
no timers basic
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
UPDATE |
Rate (in seconds) at which updates are sent. This is the fundamental timing parameter of the routing protocol. |
<5-2147483647>, default 30s |
TIMEOUT |
Time (in seconds) after which a route is declared invalid without updates that refresh the route. The route then enters into an invalid state and is not used for forwarding packets. |
It is marked inaccessible and advertised as unreachable. <5-2147483647>, default 180s |
INVALID |
Time after which an invalid route is removed from RIP routing database. |
<5-2147483647>, default 120s |
Command Mode
Router Configuration
Default
update: 30 seconds
timeout: 180 seconds
invalid: 120 seconds
Usage
The basic timing parameters for RIP are adjustable. Because RIP is executing a distributed, asynchronous routing algorithm, these timers must be the same for all switches and access servers in the network.
In addition, an address family can have explicitly specified timers that apply to that address-family only. The timers basic command must be specified for an address family or the system Default for the timers basic command are used regardless of what is configured for RIP routing.
Examples
The following example sets updates to be broadcast every 5 seconds. If a switch is not heard from in 15 seconds, the route is declared unusable. And after 15 seconds the invalid route will be removed from RIP routing database:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# timers basic 5 15 15
Related Commands
None
6.2.18. show ip rip database
Command Purpose
Use this command to display RIP information database.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip rip database ( vrf WORD | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
vrf WORD |
VPN Routing/Forwarding instance |
Up to 15 characters |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip rip database command:
Switch# show ip rip database
Codes: R - RIP, Rc - RIP connected, Rs - RIP static, K - Kernel,
C - Connected, S - Static, O - OSPF, I - IS-IS, B - BGP
Network Next Hop Metric From If Time
Rc 1.1.1.0/24 0 eth-0-1
Rc 2.2.2.0/24 0 eth-0-2
Rc 10.0.0.0/24 0 vlan10
Related Commands
show ip rip interface
6.2.19. show ip rip interface
Command Purpose
To display summary information of Routing Information Protocol (RIP) for a specific interface, use the show ip rip interface command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip rip interface ( IFNAME | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
The interface name |
Supportphysical/aggregation/loopback/tunnel/vlaninterfaces |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip rip interface command:
Switch# show ip rip interface eth-0-1
eth-0-1 is up, line protocol is up
Routing Protocol: RIP
Receive RIP packets
Send RIP packets
Passive interface: Disabled
Split horizon: Enabled with Poisoned Reversed
IP interface address:
1.1.1.1/24
Related Commands
show ip rip database
6.2.20. version (RIP)
Command Purpose
To specify a Routing Information Protocol (RIP) version used globally by the router, use the version command in router configuration mode. To restore the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
version ( 1 | 2 )
no version
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
1 |
Specifies RIP Version 1 |
- |
2 |
Specifies RIP Version 2 |
- |
Command Mode
Router Configuration
Default
System receives only RIP Version 2 packets, and sends only Version 2 packets.
Usage
To specify RIP versions used on an interface basis, use the ip rip receive version and ip rip send version commands.
Examples
The following example enables the software to send and receive RIP Version 2 packets:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# version 2
Related Commands
ip rip receive version
ip rip send version
6.2.21. distribute-list
Command Purpose
To Filter networks in routing updates, use the distribute-list command in router configuration mode. To restore the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
distribute-list ( prefix | ) WORD ( in | out )
no distribute-list ( prefix | ) WORD ( in | out )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
prefix |
Filter prefixes in routing update |
- |
WORD |
Access-list name |
Up to 40 characters |
in |
Filter incoming routing updates |
- |
out |
Filter outgoing routing updates |
- |
Command Mode
Router Configuration
Default
None
Usage
None
Examples
The following example filters all routes from RIP:
Switch# configure terminal
Switch(config)# router rip
Switch(config-router)# distribute-list prefix 1 in
Related Commands
ip prefix-list
6.2.22. address-family
Command Purpose
Use the command enter Address Family command mode in router configuration mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
address-family ipv4 vrf WORD
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
WORD |
VPN Routing/Forwarding instance name |
Up to 15 characters |
Command Mode
Router Configuration
Default
N/A
Usage
None
Examples
The following example shows how to enter Address Family command mode:
Switch# configure terminal
Switch(config)# router bgp 1
Switch(config-router)#address-family ipv4
Related Commands
None
6.2.23. show ip protocol rip
Command Purpose
To show Routing Information Protocol (RIP), use the show ip protocol rip command in in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip protocol rip
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip rip interface command:
Switch# show ip protocol rip
Routing protocol is "rip"
Sending updates every 30 seconds with +/-5 seconds
Timeout after 180 seconds, Garbage collect after 120 seconds
Outgoing update filter list for all interface is not set
Incoming update filter list for all interface is not set
Default redistribution metric is 0
Redistributing:
connected metric default
Default version control: send version 2, receive version 2
Interface Send Recv Key-chain
Routing for Networks:
10.10.11.0/24
Routing Information Sources:
Gateway Distance Last Update Bad Packets Bad Routes
Number of routes (including connected): 0
Distance: (default is 120)
Related Commands
None
6.2.24. debug rip
Command Purpose
Use this command to specify the options for the displayed debugging information for RIP events, RIP packets. Use the no parameter with this command to disable all debugging.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug rip ( all | events | PACKET | )
no debug rip ( all | events | PACKET | )
no debug all ( rip | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
all |
All RIP debug information |
- |
events |
RIP events debug information is displayed |
- |
PACKET |
packet (recv |
send) (detail) Specifies RIP packets only |
recv |
Specifies that information for received packets be displayed |
- |
send |
Specifies that information for sent packets be displayed |
- |
detail |
Displays detailed information for the sent or received packet |
- |
Command Mode
Privileged EXEC
Default
Disabled
Usage
None
Examples
The following example displays information about the rip packets that are received and sent out from the connected router:
Switch# debug rip packet
Related Commands
show debugging rip
6.2.25. show debugging rip
Command Purpose
Use this command to display the RIP debugging status for these debugging options: nsm debugging, RIP event debugging, RIP packet debugging.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show debugging rip
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show debugging rip command:
Switch# show debugging rip
RIP debugging status:
RIP packet debugging is on
Related Commands
debug rip
6.2.26. show ip rip database database-summary
Command Purpose
Use this command to display the statistics for RIP routes.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip rip database database-summary ( vrf NAME | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
vrf NAME |
VPN Routing/Forwarding instance |
Up to 15 characters |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip rip database database-summary command:
Switch# show ip rip database database-summary
Type Count
RIP connected 1
RIP 1
Total 2
Related Commands
show ip rip database
6.2.27. show resource rip
Command Purpose
Use this command to display the route resources used by RIP protocol.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show resource rip
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show resource rip command:
Switch# show resource rip
RIP
Resource Used Capability
================================================
Routes 2 6144
Related Commands
show ip rip database