6.3. OSPF Commands
6.3.1. area authentication
Command Purpose
To enable authentication for an Open Shortest Path First (OSPF) area, use the area authentication command in router configuration mode. To remove an authentication specification of an area or a specified area from the configuration, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
area AREA-ID authentication ( message-digest | )
no area AREA-ID authentication
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
AREA-ID |
Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP address |
IP address or number in the range of 0-4294967295 |
message-digest |
(Optional) Enables Message Digest 5 (MD5) authentication on the area specified by the area-id argument |
- |
Command Mode
Router Configuration
Default
Type 0 authentication (no authentication)
Usage
Specifying authentication for an area sets the authentication to Type 1 (simple password) as specified in RFC 1247. If this command is not included in the configuration file, authentication of Type 0 (no authentication) is assumed.
The authentication type must be the same for all routers and access servers in an area. The authentication password for all OSPF routers on a network must be the same if they are to communicate with each other via OSPF. Use the ip ospf authentication-key interface command to specify this password.
If you enable MD5 authentication with the message-digest keyword, you must configure a password with the ip ospf message-digest-key interface command.
To remove the authentication specification for an area, use the no form of this command with the authentication keyword.
Examples
The following example mandates authentication for areas 0 and 10.0.0.0 of OSPF routing process 100. Authentication keys are also provided:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.168.251.201/24
Switch(config-if)# ip ospf authentication-key adcdefgh
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.56.0.201/16
Switch(config-if)# ip ospf authentication-key ijklmnop
Switch(config)# router ospf 100
Switch(config-router)# network 10.0.0.0 0.255.255.255 area 10.0.0.0
Switch(config-router)# network 192.168.0.0/16 area 0
Switch(config-router)# area 10.0.0.0 authentication
Switch(config-router)# area 0 authentication
6.3.2. area default-cost
Command Purpose
To specify a cost for the default summary route sent into a stub, use the area default-cost command in router configuration mode. To remove the assigned default route cost, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
area AREA-ID default-cost COST
no area AREA-ID default-cost
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
AREA-ID |
Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP address |
IP address or number in the range of 0-4294967295 |
COST |
default cost value |
0-16777214 |
Command Mode
Router Configuration
Default
COST: 1
Usage
The command is used only on an Area Border Router (ABR) attached to a stub.
There are two stub area router configuration commands: the stub and default-cost options of the area command. In all routers and access servers attached to the stub area, the area should be configured as a stub area using the stub option of the area command. Use the default-cost option only on an ABR attached to the stub area. The default-cost option provides the metric for the summary default route generated by the ABR into the stub area.
Examples
The following example shows how to configure a stub area and set its COST value:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.56.0.201/16
Switch(config)# router ospf 100
Switch(config-router)# network 10.0.0.0/8 area 10.0.0.0
Switch(config-router)# area 10.0.0.0 stub
Switch(config-router)# area 10.0.0.0 default-cost 20
Related Commands
None
6.3.3. area filter-list
Command Purpose
To filter prefixes advertised in type 3 link-state advertisements (LSAs) between Open Shortest Path First (OSPF) areas of an Area Border Router (ABR), use the area filter-list command in router configuration mode. To change or cancel the filter, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
area AREA-ID filter-list ( access ACCESSS-LIST-NAME | prefix PREFIX-LIST-NAME ) ( in | out )
no area AREA-ID filter-list ( access ACCESSS-LIST-NAME | prefix PREFIX-LIST-NAME ) ( in | out )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
AREA-ID |
Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP address |
IP address or number in the range of 0-4294967295 |
access |
Indicates that an accesslist is used |
- |
ACCESSS-LIST-NAME |
Name of an access list |
A string with 1-20 characters |
prefix |
Indicates that a prefix list is used |
- |
PREFIX-LIST-NAME |
Name of a prefix list |
A string with 1-20 characters |
in |
Access list or prefix list applied to prefixes advertised to the specified area from other areas |
- |
out |
Access list or prefix list applied to prefixes advertised out of the specified area to other areas |
- |
Command Mode
Router Configuration
Default
This command has no default behavior.
Usage
With this feature enabled in the “in” direction, all type 3 LSAs originated by the ABR to this area, based on information from all other areas, are filtered by the prefix list. Type 3 LSAs that were originated as a result of the area range command in another area are treated like any other type 3 LSA that was originated individually. Any prefix that does not match an entry in the prefix list is implicitly denied.
With this feature enabled in the “out” direction, all type 3 LSAs advertised by the ABR, based on information from this area to all other areas, are filtered by the prefix list. If the area range command has been configured for this area, type 3 LSAs that correspond to the area range are sent to all other areas, only if at least one prefix in the area range matches an entry in the prefix list.
If all specific prefixes are denied by the prefix list, type 3 LSAs that correspond to the area range command will not be sent to any other area. Prefixes that are not permitted by the prefix list are implicitly denied.
Examples
The following example filters prefixes that are sent from all other areas to area 1:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# area 1 filter-list prefix AREA_1 in
Related Commands
area range
6.3.4. area range
Command Purpose
To consolidate and summarize routes at an area boundary, use the area range command in router configuration mode. To disable this function, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
area AREA-ID range ( ADDRESS MASK | ADDRESS / PREFIX-LENGTH ) ( advertise | not-advertise | )
no area AREA-ID range ( ADDRESS MASK | ADDRESS / PREFIX-LENGTH }
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
AREA-ID |
Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP address |
IP address or number in the range of 0-4294967295 |
ADDRESS |
IPv4 address |
IPv4 Address |
PREFIX-LENGTH |
Prefix length of the address |
1-32 |
advertise |
Advertise this range (default) |
- |
not-advertise |
Do not advertise this range |
- |
Command Mode
Router Configuration
Default
This command is disabled by default.
Usage
The area range command is used only with Area Border Routers (ABRs). It is used to consolidate or summarize routes for an area. The result is that a single summary route is advertised to other areas by the ABR. Routing information is condensed at area boundaries. External to the area, a single route is advertised for each address range. This behavior is called route summarization.
Multiple area router configuration commands specifying the range option can be configured. Thus, OSPF can summarize addresses for many different sets of address ranges.
Examples
The following example specifies one summary route to be advertised by the ABR to other areas for all subnets on network 10.0.0.0 and for all hosts on network 192.168.110.0:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.168.110.201/24
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.168.120.201/24
Switch(config)# interface eth-0-3
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.0/8
Switch(config)# router ospf 100
Switch(config-router)# network 192.168.110.0/24 area 0
Switch(config-router)# area 10.0.0.0 range 10.0.0.0/8
Switch(config-router)# area 0 range 192.168.110.0 255.255.0.0
Related Commands
None
6.3.5. area stub
Command Purpose
To define an area as a stub area, use the area stub command in router configuration mode. To disable this function, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
area AREA-ID stub ( no-summary | )
no area AREA-ID stub ( no-summary | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
AREA-ID |
Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP address |
IP address or number in the range of 0-4294967295 |
no-summary |
(Optional) Prevents an Area Border Router (ABR) from sending summary link advertisements into the stub area |
- |
Command Mode
Router Configuration
Default
No stub area is defined.
Usage
You must configure the area stub command on all routers and access servers in the stub area. Use the area router configuration command with the default-cost keyword to specify the cost of a default internal router sent into a stub area by an ABR.
There are two stub area router configuration commands: the stub and default-cost options of the area router configuration command. In all routers attached to the stub area, the area should be configured as a stub area using the stub keyword of the area command. Use the default-cost keyword only on an ABR attached to the stub area. The default-cost keyword provides the metric for the summary default route generated by the ABR into the stub area.
To further reduce the number of link-state advertisements (LSAs) sent into a stub area, you can configure the no-summary keyword on the ABR to prevent it from sending summary LSAs (LSA type 3) into the stub area.
Examples
The following example shows how to configure a stub area and set its COST value:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.56.0.201/16
Switch(config)# router ospf 100
Switch(config-router)# network 10.0.0.0/8 area 10.0.0.0
Switch(config-router)# area 10.0.0.0 stub
Switch(config-router)# area 10.0.0.0 default-cost 20
Related Commands
None
6.3.6. area nssa
Command Purpose
To define an area as a NSSA area, use the area nssa command in router configuration mode. To disable this function, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
area AREA-ID nssa ( translator-role ( candidate | never | always ) | ) ( no-summary | ) ( no-redistribution | ) ( default-information-originate { metric METRIC_VALUE | metric-type TYPE-VALUE | } | )
no area AREA-ID nssa ( translator-role | ) ( no-summary | ) ( no-redistribution | ) ( default-information-originate | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
AREA-ID |
Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP address |
IP address or number in the range of 0-4294967295 |
candidate |
(Optional) Configure the role for ABR in NSSA area as candidate for the translator router |
- |
never |
(Optional) Configure the role for ABR in NSSA area as non-translator router |
- |
always |
(Optional) Configure the role for ABR in NSSA area as the specified translator router |
- |
no-summary |
(Optional) Prevents an Area Border Router (ABR) from sending Summary LSAs into the NSSA area |
- |
no-redistribution |
(Optional) Prevents an Area Border Router (ABR) from importing routes into the NSSA area |
- |
- default-information-originate |
(Optional) Configure an ASBR to send default type 7 LSA into the NSSA area |
- |
metric METRIC_VALUE |
(Optional) Configure metric for the default originate route |
0-16777214 |
metric-type TYPE-VALUE |
(Optional) Configure metric type for the default originate route |
1-2 |
Command Mode
Router Configuration
Default
No NSSA area is defined.
Usage
No NSSA area is configured as default. You must configure the area nssa command on all routers and access servers in the NSSA area.
There are many similarities between NSSA and stub area, neither of which propagates external routes from other area. The difference is that NSSA area can introduce and propagate external routes to the OSPF autonomous domain, while STUB area can not introduce external routes.
Examples
The following example shows how to configure a NSSA area :
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.56.0.201/16
Switch(config)# router ospf 100
Switch(config-router)# network 10.0.0.0/8 area 10.0.0.0
Switch(config-router)# area 10.0.0.0 nssa
Related Commands
None
6.3.7. auto-cost
Command Purpose
To control how Open Shortest Path First (OSPF) calculates default metrics for the interface, use the auto-cost command in router configuration mode. To assign cost based only on the interface type, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
auto-cost reference-bandwidth RATE
no auto-cost reference-bandwidth
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
RATE |
Rate in Mbps (bandwidth). |
1-4294967 |
Command Mode
Router Configuration
Default
100 Mbps
Usage
The value set by the ip ospf cost command overrides the cost resulting from the auto-cost command.Bandwidth dividing port rate is cost.
Examples
The following example changes the cost of the cost link to 1GBps:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# auto-cost reference-bandwidth 1000
Related Commands
ip ospf cost
6.3.8. clear ip ospf
Command Purpose
To clear redistribution based on the Open Shortest Path First (OSPF) routing process ID, use the clear ip ospf command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
clear ip ospf ( PID | ) process
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PID |
(Optional) Process ID |
0-65535 |
Command Mode
Privileged EXEC
Default
None
Usage
Use the PID argument to clear only one OSPF process. If the PID argument is not specified, all OSPF processes are cleared.
Examples
The following example clears all OSPF processes:
Switch# clear ip ospf process
Related Commands
None
6.3.9. compatible rfc1583
Command Purpose
To restore the method used to calculate summary route costs per RFC 1583, use the compatible rfc1583 command in router configuration mode. To disable RFC 1583 compatibility, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
compatible rfc1583
no compatible rfc1583
Command Mode
Router Configuration
Default
Not compatible with RFC 1583.
Usage
To minimize the chance of routing loops, all Open Shortest Path First (OSPF) routers in an OSPF routing domain should have RFC compatibility set identically.
Because of the introduction of RFC 2328, OSPF Version 2, the method used to calculate summary route costs has changed. Use the no compatible rfc1583 command to enable the calculation method used per RFC 2328.
Examples
The following example specifies that the router process is compatible with RFC 1583:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# compatible rfc1583
Related Commands
None
6.3.10. default-information originate (OSPF)
Command Purpose
To generate a default external route into an Open Shortest Path First (OSPF) routing domain, use the default-information originate command in router configuration mode. To disable this feature, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
default-information originate ( route-map WORD | always | metric METRIC-VALUE | metric-type TYPE-VALUE | )
no default-information originate ( route-map WORD | always | metric | metric-type | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
always |
(Optional) Always advertises the default route regardless of whether the system has a default route |
- |
metric METRIC-VALUE |
metric-value (Optional) Metric used for generating the default route. If you omit a value and do not specify a value using the default-metric router configuration command, the default metric value is 1. |
0-16777214 |
metric-type TYPE-VALUE |
(Optional) External link type associated with the default route advertised into the OSPF routing domain.It can be type 1 or type 2 LSA |
1-2 |
route-map WORD |
Route map reference |
A string with 1-20 characters |
Command Mode
Router Configuration
Default
This command is disabled by default.
Usage
Whenever you use the redistribute or the default-information router configuration command to redistribute routes into an OSPF routing domain, the switch automatically becomes an autonomous System Boundary Router (ASBR). However, an ASBR does not, by default, generate a default route into the OSPF routing domain. The system still must have a default route for itself before it generates one, except when you have specified the always keyword.
Examples
The following example specifies a metric for the default route redistributed into the OSPF routing domain and an external metric type:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# redistribute rip metric 100
Switch(config-router)# default-information originate metric 100 metric-type 1
Related Commands
redistribute (OSPF)
6.3.11. default-metric (OSPF)
Command Purpose
To set default metric values for the Open Shortest Path First (OSPF) routing protocol, use the default-metric command in router configuration mode. To return to the default state, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
default-metric METRIC-VALUE
no default-metric
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
METRIC-VALUE |
Default metric value appropriate for the specified routing protocol. |
0-16777214 |
Command Mode
Router Configuration
Default
1 for BGP routes
20 for others
Usage
The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes.
Examples
The example advertises OSPF-derived routes using RIP and assigns the Internal Gateway Protocol (IGP)-derived routes a RIP metric of 10.:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# default-metric 10
Switch(config-router)# redistribute rip
Related Commands
redistribute (OSPF)
6.3.12. distance (OSPF)
Command Purpose
To define Open Shortest Path First (OSPF) route administrative distances based on route type, use the distance command in router configuration mode. To restore the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
distance { DISTANCE | ospf [ external DIST1 ] [ inter-area DIST2 ] | [ intra-area DIST3 ] }
no distance { DISTANCE | ospf }
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
DISTANCE |
Administrative distance. An integer from 1 to 255. (Routes with a distance value of 255 are not installed in the routing table.) |
1-255 |
external DIST1 |
(Optional) Sets the distance for routes from other routing domains, learned by redistribution. Range is 1 to 255. |
1-255 |
inter-area DIST2 |
(Optional) Sets the distance for all routes from one area to another area. Range is 1 to 255. |
1-255 |
intra-area DIST3 |
(Optional) Sets the distance for all routes within an area. Range is 1 to 255. |
1-255 |
Command Mode
Router Configuration
Default
DIST1: 110
DIST2: 110
DIST3: 110
Usage
You may specify one of the keywords or use distance only to apply to all types of routes.
The distance command allows you to set a distance for an entire group of routes, rather than a specific route that passes an access list.
A common reason to use the distance command is when you have multiple OSPF processes with mutual redistribution, and you want to prefer internal routes from one over external routes from the other.
Examples
The example advertises OSPF-derived routes using RIP and assigns the Internal Gateway Protocol (IGP)-derived routes a RIP distance of 90:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# distance 90
Switch(config-router)# redistribute rip
Related Commands
None
6.3.13. distribute-list (OSPF)
Command Purpose
To filter networks received in updates or suppress networks from being advertised in updates, use the distribute-list command in router configuration mode. To cancel this function, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
distribute-list prefix PREIFX-LIST-NAME ( in | out )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PREFIX-LIST-NAME |
Name of a prefix list to be applied |
A string with 1-20 characters |
Command Mode
Router Configuration
Default
None
Usage
This command must specify an access list.
Examples
In the following example, OSPF process 1 is configured to accept network 20.0.0.0/8.:
Switch# configure terminal
Switch(config)# ip prefix-list plist permit 20.0.0.0/8
Switch(config)# router ospf 100
Switch(config-router)# network 20.0.0.0/8 area 0
Switch(config-router)# distribute-list prefix plist in
Related Commands
None
6.3.14. distribute-list (OSPF)
Command Purpose
To filter networks received in updates or suppress networks from being advertised in updates, use the distribute-list command in router configuration mode. To cancel this function, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
distribute-list ACCESSS-LIST-NAME ( in | out )
no distribute-list ACCESSS-LIST-NAME ( in | out )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
ACCESSS-LIST-NAME |
Name of an access list to be applied |
A string with 1-20 characters |
in |
Filter networks received in updates |
- |
out |
Suppress networks from being advertised in updates |
- |
Command Mode
Router Configuration
Default
None
Usage
This command must specify an access list.
Examples
In the following example, OSPF process 1 is configured to accept two networks, network 20.0.0.0 and network 10.108.0.0:
Switch# configure terminal
Switch(config)# ip access-list acl1
Switch(config-ip-acl)# permit any 20.0.0.0 0.0.255.255 any
Switch(config-ip-acl)# permit any 10.108.0.0 0.0.255.255 any
Switch(config-ip-acl)# deny any any any
Switch(config)# router ospf 100
Switch(config-router)# network 10.108.0.0/16 area 1
Switch(config-router)# distribute-list acl1 in
Related Commands
ip access-list
6.3.15. ip ospf authentication
Command Purpose
To specify the authentication type for an interface, use the ip ospf authentication command in interface configuration mode. To remove the authentication type for an interface, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf authentication ( message-digest | null | )
no ip ospf authentication
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
message-digest |
(Optional) Specifies that message-digest authentication will be used |
- |
null |
(Optional) No authentication is used. Useful for overriding password or message-digest authentication if configured for an area |
- |
Command Mode
Interface Configuration
Default
The area default is no authentication (null authentication).
Usage
Before using the ip ospf authentication command, configure a password for the interface using the ip ospf authentication-key command. If you use the ip ospf authentication message-digest command, configure the message-digest key for the interface with the ip ospf message-digest-key command.
Examples
The following example enables message-digest authentication:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# ip ospf authentication message-digest
Related Commands
area authentication
ip ospf authentication-key
ip ospf message-digest-key
6.3.16. ip ospf authentication-key
Command Purpose
To assign a password to be used by neighboring routers that are using the Open Shortest Path First (OSPF) simple password authentication, use the ip ospf authentication-key command in interface configuration mode. To remove a previously assigned OSPF password, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf authentication-key ( 8 | ) PASSWORD
no ip ospf authentication-key
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PASSWORD |
Any continuous printable string of characters that can be entered from the keyboard up to 8 bytes in length |
A string with 8 characters |
(8|) |
Specifies a hidden password will follow |
- |
Command Mode
Interface Configuration
Default
No password is specified.
Usage
The password created by this command is used as a “key” that is inserted directly into the OSPF header when the switch originates routing protocol packets. A separate password can be assigned to each network on a per-interface basis. All neighboring routers on the same network must have the same password to be able to exchange OSPF information.
Examples
The following example enables the authentication key with the string yourpass:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf authentication-key yourpass
The following example enables the authentication key with the encrypt password 91c38996a1aa5699:
Switch# configure terminal
Switch(config)# interface eth-0-2
Switch(config-if)# no switchport
Switch(config-if)# ip ospf authentication-key 8 91c38996a1aa5699
Related Commands
area authentication
ip ospf authentication
6.3.17. ip ospf cost
Command Purpose
To explicitly specify the cost of sending a packet on an interface, use the ip ospf cost command in interface configuration mode. To reset the path cost to the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf cost INTERFACE-COST
no ip ospf cost
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
INTERFACE-COST |
The cost of sending a packet on an interface |
1-65535 |
Command Mode
Interface Configuration
Default
Different port rate has different default cost.
Usage
You can set the metric manually using this command, if you need to change the default. Using the bandwidth command changes the link cost as long as this command is not used.
Examples
The following example sets the interface cost value to 65:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf cost 65
Related Commands
auto-cost reference bandwidth
6.3.18. ip ospf database-filter all out
Command Purpose
To filter outgoing link-state advertisements (LSAs) to an Open Shortest Path First (OSPF) interface, use the ip ospf database-filter all out command in interface configuration mode. To restore the forwarding of LSAs to the interface, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf database-filter all out
no ip ospf database-filter
Command Mode
Interface Configuration
Default
This command is disabled by default. All outgoing LSAs are flooded to the interface.
Usage
OSPF floods new LSAs over all interfaces in an area, except the interface on which the LSA arrives. This redundancy ensures robust flooding. However, too much redundancy can waste bandwidth and might lead to excessive link and CPU usage in certain topologies, resulting in destabilizing the network. To avoid this, use the database-filter command to block flooding of LSAs over specified interfaces.
Examples
The following example prevents flooding of OSPF LSAs to broadcast, nonbroadcast, or point-to-point networks reachable through the interface eth-0-1:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf database-filter all out
Related Commands
None
6.3.19. ip ospf dead-interval
Command Purpose
To set the interval during which at least one hello packet must be received from a neighbor before the router declares that neighbor down, use the ip ospf dead-interval command in interface configuration mode. To restore the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf dead-interval SECONDS
no ip ospf dead-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
SECONDS |
The interval during which at least one hello packet must be received from a neighbor before the router declares that neighbor down. The value must be the same for all nodes on the network |
1-65535 |
Command Mode
Interface Configuration
Default
SECONDS: The neighbor is been considered as dead in 40s by default.
Usage
The dead interval is advertised in OSPF hello packets. This value must be the same for all networking devices on a specific network.
Specifying a smaller dead interval (seconds) will give faster detection of a neighbor being down and improve convergence, but might cause more routing instability.
Examples
The following example sets the OSPF dead interval to 20 seconds:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf dead-interval 20
Related Commands
ip ospf hello-interval
show ip ospf interface
6.3.20. ip ospf hello-interval
Command Purpose
To specify the interval between hello packets that the switch sends on the interface, use the ip ospf hello-interval command in interface configuration mode. To return to the default time, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf hello-interval SECONDS
no ip ospf hello-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
SECONDS |
Interval (in seconds) during which the router must receive at least one hello packet from a neighbor or else that neighbor is removed from the peer list and does not participate in routing. The range is 1 to 65535. The value must be the same for all nodes on the network |
1-65535 |
Command Mode
Interface Configuration
Default
10 seconds (Ethernet)
30 seconds (non-broadcast)
Usage
This value is advertised in the hello packets. The smaller the hello interval, the faster topological changes will be detected, but more routing traffic will ensue. This value must be the same for all routers and access servers on a specific network.
Examples
The following example sets the interval between hello packets to 15 seconds:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf hello-interval 15
Related Commands
ip ospf dead-interval
6.3.21. ip ospf message-digest-key md5
Command Purpose
To enable Open Shortest Path First (OSPF) Message Digest 5 (MD5) authentication, use the ip ospf message-digest-key command in interface configuration mode. To remove an old MD5 key, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf message-digest-key KEY-ID md5 ( 8 | ) KEY
no ip ospf message-digest-key KEY-ID
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
KEY-ID |
An identifier in the range from 1 to 255 |
1-255 |
(8|) |
Specifies a hidden password will follow |
- |
KEY |
Alphanumeric password of up to 16 bytes |
A string with 1-16 characters |
Command Mode
Interface Configuration
Default
OSPF MD5 authentication is disabled.
Usage
All routers access the same network/sub network share the same password when using this type of authentication. For every OSPF packet, the password is used for generating/examining the “message digest” which is at the tail of the OSPF packet. This “message digest” is processed by OSPF packet and password. There may multiple password be activated on the same interface, this command line always used to transit smoothly to the new password from the old one.
Examples
The following example sets a new key 19 with the password 8ry4222:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf message-digest-key 10 md5 xvv560qle
Switch(config-if)# ip ospf message-digest-key 19 md5 8ry4222
The following example sets a new key 2 with the encrypt password 91c38996a1aa5699:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf message-digest-key 2 md5 8 91c38996a1aa5699
Related Commands
area authentication
service password-encryption
ip ospf authentication
6.3.22. ip ospf mtu
Command Purpose
To set the MTU value when sending Database Descriptor (DD) packets, use the ip ospf mtu command in interface configuration mode. To restore a default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf mtu MTU-VALUE
no ip ospf mtu
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
MTU-VALUE |
MTU value |
576-65535 |
Command Mode
Interface Configuration
Default
Decided by interface mtu
Usage
Whenever OSPF constructs packets, it uses interface MTU size as Maximum IP packet size. This command forces OSPF to use the specified value overriding the actual interface MTU size.
This command allows an administrator to configure the MTU size recognized by the OSPF protocol. It does not configure the MTU settings on the kernel. OSPF will not recognize MTU size configuration changes made to the kernel until the MTU size is updated through the CLI.
Examples
The following example sets a new MTU value when sending OSPF DD packets:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf mtu 1280
Related Commands
ip ospf mtu-ignore
6.3.23. ip ospf mtu-ignore
Command Purpose
To disable Open Shortest Path First (OSPF) maximum transmission unit (MTU) mismatch detection on receiving Database Descriptor (DD) packets, use the ip ospf mtu-ignore command in interface configuration mode. To reset to default, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf mtu-ignore
no ip ospf mtu-ignore
Command Mode
Interface Configuration
Default
OSPF MTU mismatch detection is enabled.
Usage
OSPF checks whether neighbors are using the same MTU on a common interface. This check is performed when neighbors exchange DD packets. If the receiving MTU in the DD packet is higher than the IP MTU configured on the incoming interface, OSPF adjacency will not be established.
Examples
The following example disables MTU mismatch detection on receiving DD packets:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf mtu-ignore
Related Commands
ip ospf mtu
6.3.24. ip ospf priority
Command Purpose
To set the router priority, which helps determine the designated router for this network, use the ip ospf priority command in interface configuration mode. To return to the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf priority NUMBER-VALUE
no ip ospf priority
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NUMBER-VALUE |
A number value that specifies the priority of the router. |
0-255 |
Command Mode
Interface Configuration
Default
Priority of 1
Usage
When two routers attached to a network both attempt to become the designated router, the one with the higher router priority takes precedence. If there is a tie, the router with the higher router ID takes precedence. A router with a router priority set to zero is ineligible to become the designated router or backup designated router. Router priority is configured only for interfaces to multi-access networks (in other words, not to point-to-point networks).
This priority value is used when you configure Open Shortest Path First (OSPF) for non-broadcast networks using the neighbor router configuration command for OSPF.
Examples
The following example sets the router priority value to 4:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf priority 4
Related Commands
ip ospf network
neighbor (OSPF)
6.3.25. ip ospf retransmit-interval
Command Purpose
To specify the time between link-state advertisement (LSA) retransmissions for adjacencies belonging to the interface, use the ip ospf retransmit-interval command in interface configuration mode. To return to the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf retransmit-interval SECONDS
no ip ospf retransmit-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
SECONDS |
Time (in seconds) between retransmissions. The default is 5 seconds |
1-65535 seconds |
Command Mode
Interface Configuration
Default
5 seconds
Usage
When a router sends an LSA to its neighbor, it keeps the LSA until it receives back the acknowledgment message. If the router receives no acknowledgment, it will resend the LSA. The setting of this parameter should be conservative, or needless retransmission will result. The value should be larger for serial lines and virtual links.
Examples
The following example sets the retransmit interval value:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf retransmit-interval 8
Related Commands
None
6.3.26. ip ospf transmit-delay
Command Purpose
To set the estimated time required to send a link-state update packet on the interface, use the ip ospf transmit-delay command in interface configuration mode. To return to the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf transmit-delay SECONDS
no ip ospf transmit-delay
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
SECONDS |
Time (in seconds) of link state transmit delay. The default is 1 seconds |
1-65535 |
Command Mode
Interface Configuration
Default
1 second
Usage
Link-state advertisements (LSAs) in the update packet must have their ages incremented by the amount specified in the seconds argument before transmission. The value assigned should take into account the transmission and propagation delays for the interface.
If the delay is not added before transmission over a link, the time in which the LSA propagates over the link is not considered. This setting has more significance on very low-speed links.
Examples
The following example sets the retransmit delay value to 3 seconds:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip ospf transmit-delay 3
Related Commands
None
6.3.27. ip ospf network
Command Purpose
To configure the Open Shortest Path First (OSPF) network type to a type other than the default for a given medium, use the ip ospf network command in interface configuration mode. To return to the default value, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf network ( broadcast | non-broadcast | point-to-multipoint [non-broadcast ] | point-to-point )
no ip ospf network
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
broadcast |
Sets the network type to broadcast.(Such as Ethernet,FDDI) |
- |
non-broadcast |
Sets the network type to non-broadcast multi-access (NBMA) |
- |
point-to-multipoint |
Sets the network type topoint-to-multipoint. |
- |
point-to-point |
Sets the network type to point-to-point |
- |
Command Mode
Interface Configuration
Default
Depends on the network type.
Usage
Using this feature, you can configure broadcast networks as NBMA networks when, for example, routers in your network do not support multicast addressing. You can also configure non-broadcast multi-access networks as broadcast networks. This feature saves you from needing to configure neighbors.
Configuring NBMA networks as either broadcast or non-broadcast assumes that there are virtual circuits from every router to every router or fully meshed networks. However, there are other configurations where this assumption is not true. For example, a partially meshed network. In these cases, you can configure the OSPF network type as a point-to-multipoint network. Routing between two routers that are not directly connected will go through the router that has virtual circuits to both routers. You need not configure neighbors when using this feature.
If this command is issued on an interface that does not allow it, this command will be ignored.
OSPF has two features related to point-to-multipoint networks. One feature applies to broadcast networks; the other feature applies to non-broadcast networks:
On point-to-multipoint, broadcast networks, you can use the neighbor command, and you must specify a cost to that neighbor.
On point-to-multipoint, non-broadcast networks, you must use the neighbor command to identify neighbors. Assigning a cost to a neighbor is optional.
Examples
The following example sets your OSPF network as a non-broadcast network:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.168.77.17/24
Switch(config-if)# ip ospf network non-broadcast
Related Commands
Neighbor (OSPF)
6.3.28. neighbor (OSPF)
Command Purpose
To configure Open Shortest Path First (OSPF) routers interconnecting to non-broadcast networks, use the neighbor command in router configuration mode. To remove a configuration, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
neighbor IP_ADDR { priority NUMBER | poll-interval SECONDS }
neighbor IP_ADDR ( cost COST | )
no neighbor IP_ADDR { priority | poll-interval }
no neighbor IP_ADDR ( cost | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR |
Interface IP address of the neighbor |
IPv4 Address |
priority NUMBER |
(Optional) A number that indicates the router priority value of the non-broadcast neighbor associated with the IP address specified. The default is 0. This keyword does not apply topoint-to-multipointinterfaces |
0-255 |
poll-interval |
- |
- |
cost |
- |
- |
Command Mode
Router Configuration
Default
No configuration is specified.
Usage
One neighbor entry must be included in the switch configuration for each known non-broadcast network neighbor. The neighbor address must be the the primary address of the interface.
If a neighboring router has become inactive (hello packets have not been received for the Router Dead Interval period), it may still be necessary to send hello packets to the dead neighbor. These hello packets will be sent at a reduced rate called Poll Interval.
When the router first starts up, it sends only hello packets to those routers with nonzero priority, that is, routers that are eligible to become designated routers (DRs) and backup designated routers (BDRs). After the DR and BDR are selected, DR and BDR will then start sending hello packets to all neighbors in order to form adjacencies.
Examples
The following example declares a router at address 192.168.3.4 on a non-broadcast network, with a priority of 1 and a poll interval of 180 seconds:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# neighbor 192.168.3.4 priority 1 poll-interval 180
Related Commands
ip ospf priority
6.3.29. network area (OSPF)
Command Purpose
To define the interfaces on which Open Shortest Path First (OSPF) runs and to define the area ID for those interfaces, use the network area command in router configuration mode. To disable OSPF routing for interfaces defined with the address wildcard-mask pair, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
network { IP_ADDR WILDCARD-MASK | IP-ADDRESS/PREFIX-LENGTH } area AREA-ID
no network { IP-ADDRESS WILDCARD-MASK | IP-ADDRESS/PREFIX-LENGTH } area AREA-ID
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR |
Interface IP address of the neighbor |
IPv4 Address |
WILDCARD-MASK |
IP-address-type mask that includes “don`t care” bits |
IPv4 mask |
PREFIX-LENGTH |
Prefix length for the network |
1-32 |
AREA-ID |
Area that is to be associated with the OSPF address range. It can be specified as either a decimal value or as an IP address |
IP address or number in the range of 0-4294967295 |
Command Mode
Router Configuration
Default
This command is disabled by default.
Usage
The IP-ADDRESS and WILDCARD-MASK arguments together allow you to define one or multiple interfaces to be associated with a specific OSPF area using a single command.
Examples
The following partial example initializes OSPF routing process 109, and defines four OSPF areas 10.9.50.0, 2, 3, and 0. Areas 10.9.50.0, 2, and 3 mask specific address ranges, and area 0 enables OSPF for all other networks:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.108.20.1/24
Switch(config)# router ospf 100
Switch(config-router)# network 10.108.20.0/24 area 10.9.50.0
Switch(config-router)# network 10.108.0.0/16 area 2
Switch(config-router)# network 10.109.10.0/24 area 3
Switch(config-router)# network 0.0.0.0/0 area 0
Related Commands
router ospf
6.3.30. overflow database external
Command Purpose
Use this command to configure the size of the external database and the time the router waits before its entries to exit the overflow state.
Use the no parameter with this command to revert to default.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
overflow database external MAXLSAS RECOVERTIME
no overflow database external
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
MAXLSAS |
The maximum number of LSAs. Note that this value should be the same |
0-2147483647 |
RECOVERTIME |
The number of seconds the router waits before trying to exit the database |
0-65535 |
Command Mode
Router Configuration
Default
None.
Usage
Use this command to limit the number of AS-external-LSAs a router can receive, once it is in the wait state. It takes the number of seconds specified as the RECOVERTIME to recover from this state.
Examples
The following example shows setting the maximum number of LSAs and the time to recover from overflow state:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# network 10.108.0.0/16 area 0
Switch(config-router)# overflow database external 5 3
Related Commands
router ospf
6.3.31. passive-interface (OSPF)
Command Purpose
To disable sending routing updates for the Open Shortest Path First (OSPF) on an interface, use the passive-interface command in router configuration mode. To re-enable the sending of routing updates, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
passive-interface IFNAME
no passive-interface IFNAME
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
The interface name |
Supportphysical/aggregation/loopback/tunnel/vlaninterfaces |
Command Mode
Router Configuration
Default
Routing updates are sent on the interface.
Usage
If you disable the sending of routing updates on an interface, the particular subnet will continue to be advertised to other interfaces, and updates from other switches on that interface continue to be received and processed.
Examples
The following example sets the interface eth-0-1 as passive:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# network 10.108.0.0/16 area 0
Switch(config-router)# passive-interface eth-0-1
Related Commands
router ospf
6.3.32. redistribute (OSPF)
Command Purpose
To redistribute routes from one routing domain into Open Shortest Path First (OSPF) routing domain, use the redistribute command in router configuration mode. To disable redistribution, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
redistribute PROTOCOL [ route-map WORD ] [ tag TAG-VALUE ] [ metric METRIC-VALUE ] [ metric-type TYPE-VALUE ]
no redistribute PROTOCOL [ metric METRIC -VALUE ] [ metric-type TYPE-VALUE ]
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
route-map WORD |
Route map reference. |
A string with 1-20 characters |
PROTOCOL |
(Optional) The name of a routing protocol, or the keyword connected, or static. If you specify a routing protocol |
use one of the following keywords: static, connected, bgp, and rip |
tag TAG-VALUE |
Set tag for routes redistributed into OSPF |
0-4294967295 |
metric METRIC-VALUE |
(Optional) When redistributing other processes to an OSPF process, the default metric is 20 when no metric value is specified |
0-16777214 |
metric-type TYPE-VALUE |
For OSPF, the external link type associated with the default route advertised into the OSPF routing domain. It can be one of two values |
1-2 |
Command Mode
Router Configuration
Default
Route redistribution is disabled.
metric metric-value: 20
metric-type TYPE-VALUE: Type 2 external route
Usage
The metric value specified in the redistribute command supersedes the metric value specified using the default-metric command.
Examples
The following example redistribute the static routes into OSPF with metric 10:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# network 10.108.0.0/16 area 100
Switch(config-router)# redistribute static metric 10
Related Commands
default-metric
6.3.33. router-id (OSPF)
Command Purpose
To use a fixed router ID, use the router-id command in router configuration mode. To force Open Shortest Path First (OSPF) to use the previous OSPF router ID behavior, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
router-id IP_ADDR
no router-id
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IP_ADDR |
Router ID in IP address format |
IPv4 Address |
Command Mode
Router Configuration
Default
No OSPF routing process is defined.
Usage
You can configure an arbitrary value in the IP address format for each router. However, each router ID must be unique.
If this command is used on an OSPF router process which is already active (has neighbors), the new router-ID is used at the next reload or at a manual OSPF process restart. To manually restart the OSPF process, use the clear ip ospf command.
Examples
The following example specifies a fixed router-id:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# router-id 10.1.1.1
Related Commands
clear ip ospf
router ospf
6.3.34. router ospf
Command Purpose
To configure an Open Shortest Path First (OSPF) routing process, use the router ospf command in Global Config mode. To terminate an OSPF routing process, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
router ospf [ PROCESS-ID [ vrf VPN-NAME ] ]
no router ospf [ PROCESS-ID ]
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PROCESS-ID |
Internally used identification parameter for an OSPF routing process.If you don`t assign a PROCESS-ID, it enter process ID 0. Process ID 0 will be closed if you use the no form of this command and don`t assign PORCESS-ID. |
1-65535 |
vrf VPN-NAME |
(Optional) Specifies the name of the VPN routing and forwarding (VRF) instance to associate with OSPF VRF processes |
A string with 1-15 characters |
Command Mode
Global Config
Default
No OSPF routing process is defined.
Usage
You can specify multiple OSPF routing processes in each router. If you do not specify the process-id, the process-id will be the default 0.
Examples
The following example configures an OSPF routing process and assign a process number of 109:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)#
Related Commands
network area
6.3.35. summary-address (OSPF)
Command Purpose
To create aggregate addresses for Open Shortest Path First (OSPF), use the summary-address command in router configuration mode. To restore the default, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
summary-address PREFIX/PREFIX-LENGTH ( not-advertise | tag TAG-VALUE | )
no summary-address PREFIX/PREFIX-LENGTH ( not-advertise | tag TAG-VALUE | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PREFIX |
IP route prefix for the destination |
IPv4 Address |
PREFIX-LENGTH |
Prefix length for the network |
1-32 |
not-advertise |
(Optional) Suppress routes that match the specified prefix/mask pair. This keyword applies to OSPF only |
- |
tag TAG-VALUE |
Route tag value. The default tag is 0. |
0-4294967295 |
Command Mode
Router Configuration
Default
This command is disabled by default.
Usage
Routes learned from other routing protocols can be summarized. The metric used to advertise the summary is the largest metric of all the more specific routes. This command helps reduce the size of the routing table.
Using this command for OSPF causes an OSPF Autonomous System Boundary Router (ASBR) to advertise one external route as an aggregate for all redistributed routes that are covered by the address. For OSPF, this command summarizes only routes from other routing protocols that are being redistributed into OSPF. Use the area range command for route summarization between OSPF areas.
OSPF does not support the summary-address 0.0.0.0/0 command.
Examples
In the following example, the summary address 10.1.0.0 includes address 10.1.1.0, 10.1.2.0, 10.1.3.0, and so on. Only the address 10.1.0.0 is advertised in an external link-state advertisement:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# summary-address 10.1.0.0/16
Related Commands
area range
6.3.36. show ip ospf
Command Purpose
To display general information about Open Shortest Path First (OSPF) routing processes, use the show ip ospf command in user EXEC or privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf ( PROCESS-ID | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PROCESS-ID |
Internally used identification parameter for an OSPF routing process. It is locally assigned and can be any positive integer. A unique value is assigned for each OSPF routing process |
0-65535 |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip ospf command:
Switch# show ip ospf
Routing Process "ospf 100" with ID 11.11.11.11
Process uptime is 0 minute
Process bound to VRF default
Conforms to RFC2328, and RFC1583 Compatibility flag is disabled
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Refresh timer 10 secs
Number of incomming current DD exchange neighbors 0/5
Number of outgoing current DD exchange neighbors 0/5
Number of external LSA 0. Checksum 0x000000
Number of opaque AS LSA 0. Checksum 0x000000
Number of non-default external LSA 0
External LSA database is unlimited.
Number of LSA originated 1
Number of LSA received 3
Number of areas attached to this router: 1
Area 1
Number of interfaces in this area is 1(1)
Number of fully adjacent neighbors in this area is 1
Number of fully adjacent virtual neighbors through this area is 0
Area has no authentication
SPF algorithm last executed 00:00:38.995 ago
SPF algorithm executed 1 times
Number of LSA 4. Checksum 0x0235ff
Related Commands
None
6.3.37. show ip ospf border-routers
Command Purpose
To display the internal Open Shortest Path First (OSPF) routing table entries to an Area Border Router (ABR) and Autonomous System Boundary Router (ASBR), use the show ip ospf border-routers command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf border-routers
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip ospf border-routers command:
Switch# show ip ospf border-routers
OSPF process 100 internal Routing Table
Codes: i - Intra-area route, I - Inter-area route
i 22.22.22.22 [1] via 172.10.1.2, eth-0-10, ABR, Area 1
Related Commands
None
6.3.38. show ip ospf database
Command Purpose
To display lists of information related to the Open Shortest Path First (OSPF) database for a specific router, use the show ip ospf database command in EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf ( PROCESS-ID | ) database database-summary
show ip ospf ( PROCESS-ID | ) database ( self-originate | max-age | adv-router IP_ADDR | )
show ip ospf ( PROCESS-ID | ) database ( asbr-summary | external | network | router | summary | nssa-external | opaque-link | opaque-area | opaque-as ) ( self-originate | adv-router IP_ADDR | )
show ip ospf ( PROCESS-ID | ) database ( asbr-summary | external | network | router | summary | nssa-external | opaque-link | opaque-area | opaque-as ) LINK-STATE-ID ( self-originate | adv-router A.B.C.D | ) ]
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PROCESS-ID |
Internally used identification parameter for an OSPF routing process. It is locally assigned and can be any positive integer. A unique value is assigned for each OSPF routing process |
1-65535 |
adv-router IP_ADDR |
(Optional) Displays all the LSAs of the specified router. If no IP address is included, the information is about the local router itself (in this case, the same as self-originate) |
IPv4 Address |
LINK-STATE-ID |
(Optional) Portion of the Internet environment that is being described by the advertisement. The value entered depends on the advertisement`s LS type. It must be entered in the form of an IP address |
IPv4 Address |
asbr-summary |
(Optional)Displays information only about the autonomous system boundary router summary LSAs |
|
external |
(Optional) Displays information only about the external LSAs |
- |
network |
(Optional) Displays information only about the network LSAs |
- |
router |
(Optional) Displays information only about the router LSAs |
- |
self-originate |
(Optional) Displays only self-originated LSAs from the local router |
- |
summary |
(Optional) Displays information only about the summary LSAs |
- |
nssa-external |
(Optional) Displays information only about the nssa-external LSAs |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip ospf database command when no arguments or keywords are used:
Switch# show ip ospf database
Router Link States (Area 3 [Stub])
Link ID ADV Router Age Seq CkSum Link count
10.0.0.1 10.0.0.1 546 0x80000089 0x4567 1
Related Commands
None
6.3.39. show ip ospf interface
Command Purpose
To display Open Shortest Path First (OSPF)-related interface information, use the show ip ospf interface command in EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf interface ( IFNAME | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
(Optional) Interface name. If the interface-name argument is included, only information for the specified interface is included |
Supportphysical/aggregation/loopback/tunnel/vlaninterfaces |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output of the show ip ospf interface command when eth-0-3 is specified:
Switch# show ip ospf interface eth-0-3
eth-0-3 is up, line protocol is up
Internet Address 3.3.3.1/24, Area 3 [Stub], MTU 1500
Process ID 0, Router ID 10.0.0.1, Network Type NBMA, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 10.0.0.1, Interface Address 3.3.3.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:17
Neighbor Count is 1, Adjacent neighbor count is 0
Crypt Sequence Number is 1218176990
Hello received 0 sent 80, DD received 0 sent 0
LS-Req received 0 sent 0, LS-Upd received 0 sent 0
LS-Ack received 0 sent 0, Discarded 0
Related Commands
None
6.3.40. show ip ospf neighbor
Command Purpose
To display Open Shortest Path First (OSPF)-neighbor information on a per-interface basis, use the show ip ospf neighbor command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf neighbor [ IFNAME ] [ NEIGHBOR-ID ] [ detail ] [ all ]
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
IFNAME |
(Optional) Interface name. If the interface-name argument is included, only information for the specified interface is included |
- |
NEIGHBOR-ID |
(Optional) Neighbor ID |
- |
detail |
(Optional) Displays all neighbors given in detail (lists all neighbors) |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following is sample output from the show ip ospf neighbor command showing a single line of summary information for each neighbor:
Switch# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.199.199.137 1 FULL/DR 0:00:31 192.168.80.37 eth-0-1
172.16.48.1 1 FULL/DROTHER 0:00:33 172.16.48.1 vlan1
172.16.48.200 1 FULL/DROTHER 0:00:33 172.16.48.200 vlan2
10.199.199.137 5 FULL/DR 0:00:33 172.16.48.189 eth-0-2
Related Commands
None
6.3.41. show ip ospf summary-address
Command Purpose
To display the summary addresses redistribution Information used by OSPF, use the show ip ospf summary-address command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf summary-address
Command Mode
Privileged EXEC
Default
None
Usage
Metric equals to 16777215 means not advertise.
Examples
The following example shows how to use show ip ospf summary-address command:
Switch# show ip ospf summary-address
OSPF process 0:
10.0.0.0/8 Metric 20, Type 2, Tag 0
20.0.0.0/8 Metric 16777215, Type 0, Tag 0
Related Commands
None
6.3.42. show ip ospf route summary
Command Purpose
To display the summary of routes used by OSPF, use the show ip ospf route summary command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf ( PROCESS-ID | ) route summary
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
PROCESS-ID |
(Optional) Internal identification. It is locally assigned and can be any positive integer. The number used here is the number assigned administratively when enabling the OSPF routing process |
0-65535 |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to use show ip ospf route summary command:
Switch# show ip ospf route summary
OSPF Router with ID (10.10.10.10) (Process ID 0)
Route Type Count
(C)Connected 1
(D)Discard 1
(O)Intra area 0
(IA)Inter area 0
(E1)Ext type 1 0
(E2)Ext type 2 0
(N1)NSSA Ext type 1 0
(N2)NSSA Ext type 2 0
Total 2
Related Commands
None
6.3.43. show ip protocols ospf
Command Purpose
To display IP routing protocol process parameters and statistics of Open Shortest Path First (OSPF).use the show ip ospf protocols ospf command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip protocols ospf ( vrf WORD )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
vrf |
VPN Routing/Forwarding instance |
- |
WORD |
VPN Routing/Forwarding instance name |
A string with 1-15 characters |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to use show ip protocols ospf command:
Switch# show ip protocols ospf
Routing Protocol is "ospf 0"
Redistributing:
Routing for Networks:
Distance: (default is 110)
Related Commands
None
6.3.44. show ip ospf processes-count
Command Purpose
To display the current number and max number of router ospf processes.use the show ip ospf protocols ospf command in privileged EXEC mode.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show ip ospf processes-count
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
The following example shows how to use show ip ospf process count:
Switch# show ip ospf processes-count
OSPF processes current count 0
OSPF processes max count 200
Related Commands
None
6.3.45. timers spf
Command Purpose
To set the time of Open Shortest Path First (OSPF) calculating shortest path first (SPF). To restore the default, use the no form of this command.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
timers spf SPF-START SPF-HOLD
no timers spf
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
SPF-START |
Indicates the initial SPF schedule delay in seconds. |
0-2147483647 |
SPF-HOLD |
Indicates the minimum hold time between two consecutive SPF calculations. |
0-2147483647 |
Command Mode
Router Configuration
Default
spf-start: 5 seconds
spf-hold: 10 seconds.
Usage
None
Examples
The following example shows a router configured with the start, and hold values for the timers spf command set at 5, and 10 seconds, respectively:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# router-id 10.10.10.2
Switch(config-router)# timers spf 5 10
Switch(config-router)# redistribute static
Switch(config-router)# network 10.21.21.0/24 area 0
Switch(config-router)# network 10.22.22.0/24 area 00
Related Commands
None
6.3.46. max-concurrent-dd
Command Purpose
To specify Maximum number allowed to process DD concurrently, use the max-concurrent-dd command in router configuration mode. To restore default value, use the no form of this command
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
max-concurrent-dd NUMBER-VALUE
no max-concurrent-dd
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NUMBER-VALUE |
Number of DD process |
1-65535 |
Command Mode
Router Configuration
Default
5
Usage
None
Examples
The following example shows how to use max-concurrent-dd command:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# router-id 10.10.10.2
Switch(config-router)# max-concurrent-dd 10
Related Commands
None
6.3.47. maximum-area
Command Purpose
To specify Maximum number of ospf area, use the maximum-area command in router configuration mode. To restore default value, use the no form of this command
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
maximum-area NUMBER-VALUE
no maximum-area
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NUMBER-VALUE |
Number o f max-area |
1-4294967294 |
Command Mode
Router Configuration
Default
3000
Usage
This command used to specify Maximum number of ospf area.
Examples
The following example shows how to use maximum-area command:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# router-id 10.10.10.2
Switch(config-router)# maximum-area 100
Related Commands
None
6.3.48. refresh timer
Command Purpose
To Set refresh timer of link state database, use the refresh timer command in router configuration mode. To restore default value, use the no form of this command
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
refresh timer NUMBER-VALUE
no refresh timer
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
NUMBER-VALUE |
Number of DD process |
10-1800 |
Command Mode
Router Configuration
Default
10 seconds.
Usage
Users are not advised to modify the configuration
Examples
The following example shows how to use refresh timer command:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# router-id 10.10.10.2
Switch(config-router)# refresh timer 100
Related Commands
None
6.3.49. ip ospf bfd
Command Purpose
Use this command to enable IP BFD for ospf on an interface.
Use the “no” form of this command to disable IP BFD for ospf on an interface.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
ip ospf bfd
no ip ospf bfd
Command Mode
Interface Configuration
Default
By default IP BFD for ospf is disabled on the interface.
Usage
Use this command to enable IP BFD for ospf on an interface.
The IP BFD session should be created when ospf neighbor is created and the neighbor’s state is large than “two-way”.
The IP BFD session should be destroyed when ospf neighbor is delete or the neighbor’s state is not large than “two-way”.
Examples
In the following example, IP BFD for ospf is enabled on this interface:
Switch# configure terminal
Switch(config)# interface eth-0-1
Switch(config-if)# ip ospf bfd
Related Commands
None
6.3.50. debug ospf
Command Purpose
Use this command to specify all debugging options for OSPF. Use the no parameter with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf ( all | )
no debug ospf ( all | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
all |
enable all debugging |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf all
Related Commands
None
6.3.51. debug ospf bfd
Command Purpose
Use this command to specify debugging options for OSPF bfd. Use the no parameter with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf bfd
no debug ospf bfd
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf bfd
Related Commands
None
6.3.52. debug ospf events
Command Purpose
Use this command to specify debugging options for OSPF event troubleshooting. Use this command without parameters to turn on all the options. Use the no parameter with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf events ( abr | asbr | lsa | os | router | vlink | )
no debug ospf events ( abr | asbr | lsa | os | router | vlink | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
abr |
Displays ABR events |
- |
asbr |
Displays ASBR events |
- |
lsa |
Displays LSA events |
- |
os |
Displays OS interaction events |
- |
router |
Displays others router events |
- |
vlink |
Displays virtual link events |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf events lsa
Related Commands
None
6.3.53. debug ospf ifsm
Command Purpose
Use this command to specify debugging options for OSPF Interface Finite State Machine (IFSM) troubleshooting.
Use the no parameter with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf ifsm ( status | events | timers | )
no debug ospf ifsm ( status | events | timers | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
status |
Displays IFSM status information |
- |
events |
Displays IFSM event information |
- |
timers |
Displays IFSM TIMER information |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf ifsm timers
Related Commands
None
6.3.54. debug ospf nfsm
Command Purpose
Use this command to specify debugging options for OSPF Neighbor Finite State Machine (NFSM) troubleshooting.
Use the no parameter with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf nfsm ( status | events | timers | )
no debug ospf nfsm ( status | events | timers | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
status |
Displays NFSM status information |
- |
events |
Displays NFSM event information |
- |
timers |
Displays NFSM TIMER information |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf nfsm timers
Related Commands
None
6.3.55. debug ospf lsa
Command Purpose
Use this command to specify debugging options for OSPF Link State Advertisements (LSA) troubleshooting.
Use the no parameter with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf lsa ( flooding | generate | install | maxage | refresh | )
no debug ospf lsa ( flooding | generate | install | maxage | refresh | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
flooding |
Displays LSA flooding |
- |
generate |
Displays LSA generate |
- |
install |
Displays LSA installation |
- |
maxage |
Displays the maximum age of LSA in seconds |
- |
refresh |
Displays LSA refresh |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf lsa install
Related Commands
None
6.3.56. debug ospf packet
Command Purpose
Use this command to specify debugging options for OSPF packets.
Use the no parameter with this command to disable this function…
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf packet PARAMETERS
no debug ospf packet PARAMETERS
PARAMETERS = dd | detail | hello | ls-ack | ls-request | ls-update | recv | send
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
dd |
Specifies debugging for OSPF database descriptions |
- |
detail |
Sets the debug option to detailed information |
- |
hello |
Specifies debugging for OSPF hello packets |
- |
ls-ack |
Specifies debugging for OSPF link state acknowledgments |
- |
ls-request |
Specifies debugging for OSPF link state requests |
- |
ls-update |
Specifies debugging for OSPF link state updates |
- |
recv |
Specifies the debug option set for received packets |
- |
send |
Specifies the debug option set for sent packets |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf packet dd send detail
Related Commands
None
6.3.57. debug ospf route
Command Purpose
Use this command to specify which route calculation to debug. Use this command without parameters to turn on all the options.
Use the no parameter with this command to disable this function.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
debug ospf route ( ase | ia | install | spf | )
no debug ospf route ( ase | ia | install | spf | )
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
ase |
Specifies the debugging of external route calculation |
- |
ia |
Specifies the debugging of Inter-Area route calculation |
- |
install |
Specifies the debugging of route installation |
- |
spf |
Specifies the debugging of SPF calculation |
- |
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
Switch# debug ospf route install
Related Commands
None
6.3.58. show debugging ospf
Command Purpose
Use this command to display the set OSPF debugging option…
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show debugging ospf
Command Mode
Privileged EXEC
Default
None
Usage
None
Examples
This is a sample output from the show debugging ospf command:
Switch# show debugging ospf
OSPF debugging status:
OSPF packet Hello send debugging is on
OSPF packet Database Description send debugging is on
OSPF packet Link State Request send debugging is on
OSPF packet Link State Update send debugging is on
OSPF packet Link State Acknowledgment send debugging is on
OSPF route installation debugging is on
Related Commands
None
6.3.59. show resource ospf
Command Purpose
Use this command to display the route resources used by OSPF protocol.
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
show resource ospf
Command Mode
Privileged EXEC
Default
None
Usage
If you do not use OSPF, value of capability is 0.
Examples
The following is sample output from the show resource ospf command:
Switch# show resource ospf
OSPF
Resource Used Capability
================================================
Routes 1 6144
Related Commands
show ip ospf route summary
6.3.60. min-lsa-interval
Command Purpose
Configure the
minimum interval between the same LSAs
Prerequisites
Platform |
Software |
License |
Comments |
---|---|---|---|
AQ-N3000 |
7.0 |
Base |
|
AQ-N5000 |
7.0 |
Base |
|
AQ-N6000 |
7.0 |
Base |
Command Syntax
min-lsa-interval SECONDS
no min-lsa-interval
Parameter |
Parameter Description |
Parameter Value |
---|---|---|
SECONDS |
The minimum interval between the same LSAs |
0-10 |
Command Mode
Router Configuration
Default
The default interval is 5
Usage
Only if you use OSPF,
you can configure the value range from 0 to 10 second
Examples
The following is a sample to configure the MinLSInteval:
Switch# configure terminal
Switch(config)# router ospf 100
Switch(config-router)# min-lsa-interval 3
Related Commands
None